GRC ShieldsUP! detects open ports



  • so i did a test on my pfsense box today and grc ShieldsUP says:

    –--------------------------------------------------------------------

    GRC Port Authority Report created on UTC: 2010-01-19 at 07:34:48

    Results from scan of ports: 0-1055

    1 Ports Open
        2 Ports Closed
    1053 Ports Stealth

    1056 Ports Tested

    The port found to be OPEN was: 80

    Ports found to be CLOSED were: 0, 1

    Other than what is listed above, all ports are STEALTH.

    TruStealth: FAILED - NOT all tested ports were STEALTH,
                      - NO unsolicited packets were received,
                      - NO Ping reply (ICMP Echo) was received.


    Quote: "Solicited TCP Packets: RECEIVED (FAILED)  — As detailed in the port report below, one or more of your system's ports actively responded to our deliberate attempts to establish a connection. It is generally possible to increase your system's security by hiding it from the probes of potentially hostile hackers. Please see the details presented by the specific port links below, as well as the various resources on this site, and in our extremely helpful and active user community."

    So i assume its talking about port 80 here. what can i do to fix this?



  • Port 80 is probably the http port for the pfSense web GUI. (Thats the default. It can be changed if you wish.)

    There can be good reason to keep the web GUI accessible from the WAN, but if you don't like it, you can add a firewall rule to block that. The web GUI is password protected so it might not be a big security risk, but if you are serious about security you should probably change the web GUI from plaintext (http) to encrypted (https).



  • With the default rules, grc doesn't detect open ports with me. How are you connecting to the internet? where does your wan interface connect to?



  • Yes. these are default options in pfsenes.

    I am connecting the wan port to a VSAT satellite modem.

    the modem has no port 80!



  • modems do, all ip devices do, its not detecting the modem but pfSense. the modem just forwards all requests to the fw. most modems ports are only accessible on private ips (you and your isp can access it)
    for example cox gives private class a ips to all modems and a public one

    try to connect to yourip.com, chances are it will connect to pf.



  • No. By default the webgui is not open on the WAN. There are no open ports on a default install. If you are failing the shields up test you configured something wrong. Or it's not coming from your firewall.



  • Exactly my point.



  • thats why you need to connect to that port to see whats using it.
    have upnp enabled? check nat entries.



  • No. By default the webgui is not open on the WAN. There are no open ports on a default install. If you are failing the shields up test you configured something wrong. Or it's not coming from your firewall.

    what he said ^

    Satellite…  dont they put you on a proxy?  The results may be showing you something related to the noc...


Locked