Need to Fix Stupid Mistake :( (SOLVED)



  • Hi everyone,

    I was working with SSH to clean up some left over bits from Squid and I stupidly deleted the whole /usr/local/etc folder. (stupid me using rm-Rf)

    I put the root /etc back and then I managed to uninstall the packages and reinstall them which seemed to add some stuff back to that folder and the packages are working fine. I am worried about what else may have been lost though. I am afraid to reboot the firewall because of this. I have this gut feeling it isn't coming back up. I went into the console and tried something simple like restarting the web configurator and it gave errors. It complained about some PEAR stuff not being found.

    Is there anyway I can correct this issue without reinstalling the whole system? Btw, I don't have a file level backup of the server… just the backup file (config.xml) the backup tool gives you. We have Retrospect but I could never get the client to install on pfsense.

    I am hoping I can find out what important files existed in that folder and copy them back from somewhere... or someone.

    Thanks.

    P.S. You can all start rolling on the floor and laugh at me now. :(



  • I figured this out myself. I had a hunch that reapplying the 1.2.3 full update would fix any missing files and this seems to be the case. /usr/local/etc is full of files now and no errors on starting services and the reboot worked without a hitch.


Locked