PfSense 2.0 downgrade embedded without openening box?



  • Hi there,

    Is it possible for me to downgrade to 1.2.3 without having to open up my alix box? Can I somehow dd the image to the second slice and then boot up from there? I do not care if I loose my conf, I can redo this, but I do not want to open this box again ;)

    Thanks!



  • You may be able to do it by restoring your 1.2.3 config, using the upgrade process to install 1.2.3, and then restoring your 1.2.3 config again (may possibly need to reset to defaults before this last step).



  • Okay. But you are not entirely sure?



  • In my case, I cannot test it because upgrading from 2.0 beta builds isn't working.  I still have 1.2.3 on the other slice as a result of this.  I do need to restore my 1.2.3 config before booting into it or it is completely unusable.  This may be partly a result of starting with a new config for 2.0 instead of upgrading my old one.

    I'm not sure whether there is really any need to do it, but I always clear out the configuration settings before restoring a different one.  You definitely do need to restore the 1.2.3 configuration after putting that version back on, though.

    Hmm, if you want something closer to what I have actually tested, this might be better: do the upgrade to 1.2.3 and if it isn't usable enough to restore your configuration (if the web GUI doesn't work and the console menu won't work either for resetting to defaults), boot back into 2.0 and restore your 1.2.3 configuration without booting 2.0 afterward and 1.2.3 should at least be usable enough to restore your old configuration.  Even if it appears to work fine, you should restore the configuration from within 1.2.3 once it is usable.  Various components will give error messages here and there if you don't.

    I recall you mentioning in another thread that you do have a configuration backup from 1.2.3.  In my case I wouldn't have been able to get 1.2.3 working again without it, except by taking out the card to recopy the OS and start out fresh, since otherwise I can't get it back into a state where either the web GUI or console menu will work.



  • I have solved the problem of not wanting to open my standard alix enclosure different. I took a dremel to the case and made a slot where te CF card is. Helps if you are "playing" a lot with pfsense.  ;D. On the subject of downgrading, i haven't tried…


  • Rebel Alliance Developer Netgate

    You might be able to downgrade if you do it this way:

    1. Set boot slice back to 1.2.3
    2. delete or move the 2.0 config.xml from /conf/
    3. Copy a 1.2.3 config.xml into /conf/
    4. Reboot

    Edit: I second the notion of putting a CF slot in the ALIX case. I have done that with mine and it works quite well. http://twitpic.com/8rjtu


Locked