Problems with vlan's on lagg interfaces



  • Using the current snapshot pfSense-2.0-BETA1-20100217-2217 I am unable to assign VLANs to a LAGG0 interface using the web GUI.  I can see other interfaces in VLAN edit but not the newly created LAGG0 interface.  Did a backup of the server to an XML file and was able to create and assign the VLANs to the LAGG0 group editing the XML file and doing a restore. Everything is working on the LAGG0 interface fine this way.  Just wondering how to get the LAGG0 to show up in VLAN edit on the Web GUI.



  • I just did exactly that setup a week or two ago and it worked fine. Just now created a lagg group, went to add a VLAN, and lagg0 was there as an option for the parent. Using the newest snapshot.

    Can you paste the lagg part of your config.xml?



  • Here is the sections of my config.xml file that contains the VLAN's, LAGG and Interface assignments.  Another thing is my network has (4) 1Gbps links.  The lagg0 bandwidth shows up as 100Mb.  I use pfSense as a router on a stick for my entire network.

    <interfaces><lan><if>lagg0</if>
    <media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
    <descr>LAN</descr>
    <enable><ipaddr>10.0.1.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></mediaopt></media></lan>
    <opt2><descr>VLAN10_Servers</descr>
    <if>lagg0_vlan10</if>
    <enable><ipaddr>10.0.10.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt2>
    <opt3><descr>VLAN20_Printers</descr>
    <if>lagg0_vlan20</if>
    <enable><ipaddr>10.0.20.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt3>
    <opt4><descr>VLAN30_Multimedia</descr>
    <if>lagg0_vlan30</if>
    <enable><ipaddr>10.0.30.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt4>
    <opt5><descr>VLAN40_VoIP</descr>
    <if>lagg0_vlan40</if>
    <enable><ipaddr>10.0.40.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt5>
    <opt6><descr>VLAN50_Workstations</descr>
    <if>lagg0_vlan50</if>
    <enable><ipaddr>10.0.50.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt6>
    <opt7><descr>VLAN60_Wireless</descr>
    <if>lagg0_vlan60</if>
    <enable><ipaddr>10.0.60.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt7>
    <opt8><descr>VLAN99_Management</descr>
    <if>lagg0_vlan99</if>
    <enable><ipaddr>10.0.99.1</ipaddr>
    <subnet>24</subnet>
    <spoofmac></spoofmac></enable></opt8>
    <wan><if>re0</if>
    <blockpriv><media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
    <descr>WAN</descr>
    <enable><ipaddr>dhcp</ipaddr>
    <dhcphostname><alias-address><alias-subnet>32</alias-subnet>
    <spoofmac></spoofmac></alias-address></dhcphostname></enable></mediaopt></media></blockpriv></wan></interfaces>

    <vlans><vlan><if>lagg0</if>
    <tag>10</tag>
    <descr>VLAN10_Servers</descr>
    <vlanif>lagg0_vlan10</vlanif></vlan>
    <vlan><if>lagg0</if>
    <tag>20</tag>
    <descr>VLAN20_Printers</descr>
    <vlanif>lagg0_vlan20</vlanif></vlan>
    <vlan><if>lagg0</if>
    <tag>30</tag>
    <descr>VLAN30_Multimedia</descr>
    <vlanif>lagg0_vlan30</vlanif></vlan>
    <vlan><if>lagg0</if>
    <tag>40</tag>
    <descr>VLAN40_VoIP</descr>
    <vlanif>lagg0_vlan40</vlanif></vlan>
    <vlan><if>lagg0</if>
    <tag>50</tag>
    <descr>VLAN50_Workstations</descr>
    <vlanif>lagg0_vlan50</vlanif></vlan>
    <vlan><if>lagg0</if>
    <tag>60</tag>
    <descr>VLAN60_Wireless</descr>
    <vlanif>lagg0_vlan60</vlanif></vlan>
    <vlan><if>lagg0</if>
    <tag>99</tag>
    <descr>VLAN99_Management</descr>
    <vlanif>lagg0_vlan99</vlanif></vlan></vlans>

    ...

    <laggs><lagg><members>em0,em1,em2,em3</members>
    <descr><laggif>lagg0</laggif>
    <proto>roundrobin</proto></descr></lagg></laggs>



  • Just upgraded to the latest snapshot and the option is still not there for lagg0 as a parent interface.  Any other suggestions?



  • Not sure if this helps but the network cards are all intel that are part of the lagg group.  Tried upgraded to the latest firmware as of March 3 and still do not see the parent interface listed in the VLANS tab.



  • Can you show an ifconfig command output after lagg device has been created?



  • $ ifconfig
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=19b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21b:21ff:fe1b:fd2c%em0 prefixlen 64 scopeid 0x1
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    em1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=19b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21b:21ff:fe20:aa9f%em1 prefixlen 64 scopeid 0x2
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    em2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=19b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4>ether 00:1b:21:1b:fd:2c
    inet6 fe80::215:17ff:fe16:9900%em2 prefixlen 64 scopeid 0x3
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    em3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=19b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21b:21ff:fe20:aaf1%em3 prefixlen 64 scopeid 0x4
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    lagg0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=19b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21b:21ff:fe1b:fd2c%lagg0 prefixlen 64 scopeid 0xc
    inet 10.0.1.1 netmask 0xffffff00 broadcast 10.0.1.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    laggproto roundrobin
    laggport: em3 flags=4 <active>laggport: em2 flags=4 <active>laggport: em1 flags=4 <active>laggport: em0 flags=4 <active>lagg0_vlan10: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21f:d0ff:fe88:aca8%lagg0_vlan10 prefixlen 64 scopeid 0xd
    inet 10.0.10.1 netmask 0xffffff00 broadcast 10.0.10.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    vlan: 10 parent interface: lagg0
    lagg0_vlan20: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21f:d0ff:fe88:aca8%lagg0_vlan20 prefixlen 64 scopeid 0xe
    inet 10.0.20.1 netmask 0xffffff00 broadcast 10.0.20.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    vlan: 20 parent interface: lagg0
    lagg0_vlan30: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21f:d0ff:fe88:aca8%lagg0_vlan30 prefixlen 64 scopeid 0xf
    inet 10.0.30.1 netmask 0xffffff00 broadcast 10.0.30.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    vlan: 30 parent interface: lagg0
    lagg0_vlan40: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21f:d0ff:fe88:aca8%lagg0_vlan40 prefixlen 64 scopeid 0x10
    inet 10.0.40.1 netmask 0xffffff00 broadcast 10.0.40.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    vlan: 40 parent interface: lagg0
    lagg0_vlan50: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21f:d0ff:fe88:aca8%lagg0_vlan50 prefixlen 64 scopeid 0x11
    inet 10.0.50.1 netmask 0xffffff00 broadcast 10.0.50.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    vlan: 50 parent interface: lagg0
    lagg0_vlan99: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:1b:21:1b:fd:2c
    inet6 fe80::21f:d0ff:fe88:aca8%lagg0_vlan99 prefixlen 64 scopeid 0x12
    inet 10.0.99.1 netmask 0xffffff00 broadcast 10.0.99.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    vlan: 99 parent interface: lagg0</performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></active></active></active></active></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4></up,broadcast,running,simplex,multicast>



  • You have your vlans ok as i can see!
    Though upgrade to latest version it should be ok. Not sure where is the problem.



  • Started over again using the latest March 9th AMD64 snapshot and still was unable to see the lagg0 as the parent interface for VLAN edit.  Even tried doing a VLAN on the interface after reboot and still was not there for an option.



  • Give me access to this system than!



  • That may be a 64 bit issue only, it definitely works fine every time I've done it, though I only am using 32 bit builds. You probably have no benefit in using 64 bit anyway, try 32 bit and see if that makes any difference.



  • Same probleme with 2.0-BETA4  (i386) built on Wed Sep 22 22:49:23 EDT 2010 FreeBSD 8.1-RELEASE-p1

    Not a 64 bit issue only, it's a LAGG type issue.

    The probleme seem occur with a "fec" LAAG not with a lacp "LAGG"

    fec: Supports Cisco EtherChannel. This is a static setup and does not negotiate aggregation with the peer or exchange frames to monitor the link.

    Thank in advance.


Log in to reply