Dynamic Firewall Log broken



  • The dynamic view of System Logs: Firewall appears to be broken. The first and subsequent updates present the same 4 lines from earlier in the log.  This affects the firewall log view in dashboard as well.


  • Rebel Alliance Developer Netgate

    Did this just happen recently? It's fine on a box I've got from about 10 days ago. I'm updating it now to try again.


  • Rebel Alliance Developer Netgate

    Just tried it from a snap from this morning and it's working fine there, too.



  • And indeed it now works on my box, dated from Sunday  ???.  All I did was to reverse the log (it still made the error!) and then switch it back only to see it working. Guess I should have done that before reporting, though it did carry the behaviour across an upgrade.

    Will keep an eye out for a repeat…..

    thanks



  • My pfSense has restarted the old log entry insertion.  Noticed that I need a certain number of entries in the log before this behaviour appears.  A frequently updated box on a low traffic network may not show it.

    At present it displays 16 lines back in log.



  • Some more information/ detail.  Am on 2.0-BETA1 built on Fri Feb 26 23:14:37 EST 2010. Note my post above as to conditions under which this appears.

    First attached image shows (if the crappy rez allows!) normal view firewall log with top 2 entries straddling 1 & 2 March.

    Second image shows dynamic view after first update - the 2 March entry now at bottom of list and the last 1 March entry now at top.  Next update replaced the 2 March entry at list bottom with a duplicate of the 1 March entry, and so it goes.

    I doubt this is peculiar to my setup but am happy to be proven wrong….





  • Rebel Alliance Developer Netgate

    Ah… ok. Splitting across a time boundary like Midnight is not something I have tested.

    I'll have to take a look and see if I can tell where that bug might be. There are a couple other bugs in the log updating that I'm chasing anyhow.


Log in to reply