Pppoe after manual disconnect and reconnect wont allow internet access



  • currently in on the 27th feb nanobsd snapshot the pppoe auto reconenct to isp remains as mentioned in the previous threads but the other issue for me is on reboot of the alix, WAN is connected but suppose if i go to interfaces and click disconnect and then connect, then it connects to the isp and gets the new ip also but i guess something seems to be missing as after this manual disconnect and reconnect, inspite of having the WAN ip provided by isp, pfsense wont route packets to the internet, meaning still there is no internt access inspite of being very well connected so i guess it misses something while adding routes etc and could be also because in the mac address field it keeps showing  00:00:00:00:00:00


  • Rebel Alliance Developer Netgate

    Are you sure it isn't routing? Or just isn't doing DNS?

    I've seen reconnect issues where it left the system with a resolv.conf that lacked DNS servers, but would still route traffic if done completely by IP.



  • i have a zero mac but my connection works fine with disconnect/reconnect. i am using the mpd5 binary described in my mlppp hack thread and not the official one and i don't have this problem. i believe they put the mpd5.5 binary into newer builds. you can try to confirm this (mpd5 -v) and perhaps use an older build such as Thu Feb 25 00:09:28 EST 2010 which uses the mpd4 binary.


  • Rebel Alliance Developer Netgate

    Yes, the mpd5 binary is in current builds:

    [root@tester.bench]/root(1): which mpd5
    /usr/local/sbin/mpd5
    


  • it gets the ip from isp and the dns ip i have it manually feeded rather than depending on the isp supplied so its got to be the  routing i guess.

    no idea what mpd is currently there in this snapshot, plz provide commands to check that.

    second issue is pppoe periodic reset doesnt work also.

    –-update----
    sorry if i misunderstood the previous posts,a ctually it doesnt route even by domain name or IP address, tried both



  • this problem still is there in pppoe on the 18th march nanobsd snapshot, basically what happens is, firstly, inspite of Enable Dial-On-Demand mode being ticked under WAN, if u go to interfaces and disconnect then no matter how much u wait and try to generate internet traffic, pppoe is still not brought up and even if u try to go to interfaces and click connect, then it connects just fine to the isp and gets ip etc but non of the lan PC r still able to surf but if u try a DNS lookup then that resolves just fine so its like, pfsense is conencted to the itnernet, the routes also set properly but something missing so no other traffic flows other than DNS queries which mayb bcoz pfsense dns forwarer is enabled and the proff of something still no been configured properly is the below entry in system log:

    igmpproxy: Note: Route is not active. No kernel updates done.

    so if pppoe drops then i have to manually reboot the alix to get it to connect and route properly

    first 2 images when pppoe is conencted on alix reboot and everything is up and fine

    next 2 images when pppoe is disconnected and then reconnected but DNS queries work but not able to surf from LAN










  • also get this on the 20th march nanobsd snapshot which sued to come from the past few snapshots

    Mar 20 15:04:37 php: : The command 'route add -host 195.229.252.33' returned exit code '1', the output was 'route: writing to routing socket: Invalid argument add host 195.229.252.33: Invalid argument'
    Mar 20 15:04:37 php: : The command 'route add -host 195.229.252.33' returned exit code '1', the output was 'route: writing to routing socket: Invalid argument add host 195.229.252.33: Invalid argument'


Log in to reply