Watchguard Firebox II load / boot problem



  • Was hoping someone might have an idea of what is happening. I have a WG Firebox II unit that I have upgraded the ram and cpu. I have the the 40pin ide cable and a selection of CF cards and 2.5" hard drives. I've tried to install pfsense in every way I know how, I've searched, googled and sooked… I've loaded pfsense from the cd and gone to the 'install' option, loaded to the Cf and hdd via usb, card readers and even to the point of putting the cf card straight into the laptops ide connector.

    Once I've loaded the image onto the CF card, the laptop will boot quite happily and ask me to configure the interfaces - happy about this. But, when I insert the CF card back into the WG, it 'posts' then comes up with a menu of "F1 FreeBSD" and "F5 Drive 0". Below this option is "Boot: F1".

    Now what happens is that it will start displaying a line of ###  (they are actually ###) and go on forever. If I hit a key on the keyboard, it just displays another #.

    What is driving me round the bend is that I've read people have managed to get it to work, but no one seems to explain how. What is also confusing me is that "monowall" will load and run quite happily off the CF card.

    If any one has even the slighest clue, I'd be really grateful if you could let me know what's going on...
    Thanks heaps,
    Karl



  • So are you doing a full install or an embedded install?
    If you use a CF you should use the embedded version.

    Is your bios up to date?

    If you're using the embedded version maybe this might help:
    http://doc.pfsense.org/index.php/NanoBSD_on_WRAP



  • Thanks for the link. I re did the image and used the imbedded image written to a CF card via a usb reader. Took the card and inserted into a laptop - worked like a charm - booted and asked to setup the interfaces. Whislt I had it running, made the changes as advised in the link. Put the card into the WG and booted with a serial console. THe boot menu now comes up with three options, 1 freebsd, 2 freebsd, 5 other. After making the changes, at least it appears to want to boot, but just sits there with the cursor flashing. Redid the image, used the CD and did an embedded install, used the nano image and still the same thing. I thought after reading the link, this is it, this will fix it. Bummer, no.

    Thanks for the idea.
    Karl


Log in to reply