Package install problems



  • Just installed 2.0 and though i'd report back as its beta. Sorry if this has been reported already..

    When i try and install packages i get a error.

    The install report stops at…
    Loading package instructions...

    and the footer of the message has the error...

    Warning: fopen(/usr/local/pkg/avahi.inc): failed to open stream: Read-only file system in /etc/inc/pfsense-utils.inc on line 1551 Warning: chmod(): No such file or directory in /etc/inc/pkg-utils.inc on line 637 Warning: fopen(/usr/local/etc/avahi/ssh.service): failed to open stream: No such file or directory in /etc/inc/pfsense-utils.inc on line 1551 Warning: chmod(): No such file or directory in /etc/inc/pkg-utils.inc on line 637 Warning: fopen(/usr/local/etc/avahi/sftp-ssh.service): failed to open stream: No such file or directory in /etc/inc/pfsense-utils.inc on line 1551 Warning: chmod(): No such file or directory in /etc/inc/pkg-utils.inc on line 637 Warning: require_once(/usr/local/pkg/avahi.inc): failed to open stream: No such file or directory in /etc/inc/pkg-utils.inc on line 654 Fatal error: require_once(): Failed opening required '/usr/local/pkg/avahi.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /etc/inc/pkg-utils.inc on line 654

    i've mounted tthe filesystem as read/write ad chmod 777 of the folders its trying to write to and still getting errors

    Anyone had this problem or have any idea how to fix this

    thanks



  • found patch for file in known problems. sorry to bother you


Log in to reply