Problems flashing to USB drive [SOLVED]



  • I have tried flashing the newest 1.2.3 release images to USB drives, both 512MB image and a 1GB image (to 512mb drive and 1gb drive), but no success. I have used physdrivewrite v. 0.5.2, WinImage and a tool which I don't remember the name of (from a russian webpage). I remembered to unpack the img file inside the gz archive.

    I have tried booting from the USB drives on three different laptops and one stationary computer, but none of them boots up pfSense from the USB drives. I know the computers are able to boot from USB drives, because I have successfully booted from my MS DOS USB drive.

    I have tried flashing the USB drives from other computers, but it's the same problem.

    I am insisting to run pfSense from USB drive because the firewall will be running without hdd to make it as silent as possible.

    Any suggestions? Did I overlook something important?

    Extra info: When booting, the cursor is blinking in the upper left position on the screen, and nothing more happens.



  • I'm in the same situation, and experienced the same behavior.

    I want to run pfSense from a 4GB USB thumb drive.

    After fairly extensive searching yesterday, it appears that it should be possible, but will require some work.  Tonight I'll dive a little deeper and see if I can find a resolution.  My guess right now is that the boot block in the image is the culprit, somehow not being proper for a USB device.


  • Rebel Alliance Developer Netgate

    If you are using the NanoBSD images, all output goes to the serial console, not the video/keyboard console. Do you have a null modem cable connected to a serial port to see if it's booting up there?



  • I was under the impression that I'd see a little output on the VGA before it switched over to the serial console.  I recall reading that a slash ("/") would display immediately prior to the serial redirection starting.  Currently, all I see post-POST is a blinking cursor in the upper left corner.


  • Rebel Alliance Developer Netgate

    That may depend on the BIOS. You'll need a serial console to configure the interfaces anyhow, so there really isn't much point in testing it without a null modem cable hooked up.



  • I haven't owned any RS-232-capable equipment for years.  I'd like to keep it that way.

    After further research, I've concluded that I have some use cases (not just VGA console, but others) that aren't really a good match for pfSense.  I will be better served by generating a custom FreeBSD image, perhaps using the NanoBSD tool.  Thus I'm going to exit the conversation in this thread.

    Paalgg, I agree with jimp's direction regarding the null modem cable.



  • Do you have a null modem cable connected to a serial port to see if it's booting up there?

    @SecretAsianMan:

    Paalgg, I agree with jimp's direction regarding the null modem cable.

    There we go, that's my problem. :)

    I guess I have a null modem cable somewhere from old days actually.



  • I have also had this problem see my post here

    http://forum.pfsense.org/index.php/topic,24753.msg128448.html#msg128448

    replacing the mbr fixes the boot for me.

    you should see some indication of booting on the screen, I always get
    a backslash with blinking cursor then the text

    
    BTX loader 1.00   BTX version is 1.02
    
    

    everything else goes out on the serial port.

    .


Log in to reply