Squid/ havp & Videocache



  • With video cache running Should I have squid set to transparent and havp as a parent to squid ?
    OR
    Squid NO  transparent and Havp transparent on with parent proxy set to lan IP port 3128?

    Video cache doesn't seem to work.

    While I have you here Does the Urlgrabber and Iniparse addons so up with the pkg_Info command ?
    Thanks
    Allan



  • Below I see PHP is owned by root , Is it suppose to be owned by proxy ?

    Diagnostics: Execute command

    $ top
    last pid: 22934;  load averages:  0.00,  0.00,  0.00  up 0+02:30:14    12:10:14
    90 processes:  1 running, 83 sleeping, 6 zombie

    Mem: 164M Active, 48M Inact, 128M Wired, 72K Cache, 110M Buf, 644M Free
    Swap: 2048M Total, 2048M Free

    PID USERNAME  THR PRI NICE  SIZE    RES STATE  C  TIME  WCPU COMMAND
      944 root        1  -8    0 45832K 19940K piperd 0  0:05  0.10% php
    1862 proxy      1  4    0 19484K 14272K kqread 0  0:07  0.00% squid
    1826 havp        1  4    0  6376K  5028K accept 0  0:02  0.00% havp
    1477 root        1  8  20  3492K  1432K wait  0  0:01  0.00% sh
      880 root        1  4    0  5144K  2856K kqread 1  0:00  0.00% lighttpd
      934 root        1  4    0 45832K 18848K accept 0  0:00  0.00% php
    1892 root        1  8  20  3156K  800K nanslp 1  0:00  0.00% check_reload_status
    1820 havp        1  4    0  6376K  4996K accept 0  0:00  0.00% havp
      613 root        1  44    0  3268K  1640K select 1  0:00  0.00% inetd
    1823 havp        1  4    0  6376K  4992K accept 0  0:00  0.00% havp
      949 nobody      1  44    0  3156K  1340K select 1  0:00  0.00% dnsmasq
    1814 havp        1  8    0  5352K  3140K nanslp 1  0:00  0.00% havp
    1902 root        1 -58    0  5260K  2532K bpf    1  0:00  0.00% bandwidthd
    1651 root        1 -58    0  5260K  2300K bpf    0  0:00  0.00% bandwidthd
    1904 root        1 -58    0  5260K  2464K bpf    0  0:00  0.00% bandwidthd
    1652 root        1 -58    0  5260K  2248K bpf    0  0:00  0.00% bandwidthd
    1903 root        1 -58    0  5260K  2480K bpf    0  0:00  0.00% bandwidthd
    1653 root        1 -58    0  5260K  2232K bpf    0  0:00  0.00% bandwidthd



  • This is a tidbit from my squid log .  Is it correct to have 2 python processes?  with videocache

    2010/03/09 09:39:26| Preparing for shutdown after 54 requests
    2010/03/09 09:39:26| Waiting 3 seconds for active connections to finish
    2010/03/09 09:39:26| FD 19 Closing HTTP connection
    2010/03/09 09:39:26| FD 20 Closing HTTP connection
    2010/03/09 09:39:26| WARNING: url_rewriter #1 (FD 12) exited
    2010/03/09 09:39:26| Too few url_rewriter processes are running
    2010/03/09 09:39:26| Starting new helpers
    2010/03/09 09:39:26| helperOpenServers: Starting 2 'python' processes
    2010/03/09 09:39:26| WARNING: url_rewriter #2 (FD 13) exited
    2010/03/09 09:39:30| Shutting down...
    2010/03/09 09:39:30| Closing unlinkd pipe on FD 18
    2010/03/09 09:39:30| storeDirWriteCleanLogs: Starting...
    2010/03/09 09:39:30|   Finished.  Wrote 5816 entries.
    2010/03/09 09:39:30|   Took 0.0 seconds (1293882.1 entries/sec).
    CPU Usage: 0.602 seconds = 0.385 user + 0.217 sys
    Maximum Resident Size: 10336 KB
    Page faults with physical i/o: 4
    2010/03/09 09:39:30| logfileClose: closing log /dev/null
    2010/03/09 09:39:30| Squid Cache (Version 2.7.STABLE7): Exiting normally.
    2010/03/09 09:41:14| Starting Squid Cache version 2.7.STABLE7 for i386-portbld-freebsd7.0...
    2010/03/09 09:41:14| Process ID 1862
    2010/03/09 09:41:14| With 11095 file descriptors available
    2010/03/09 09:41:14| Using kqueue for the IO loop
    2010/03/09 09:41:14| DNS Socket created at 0.0.0.0, port 59728, FD 11
    2010/03/09 09:41:14| Adding domain cbexpress.cb from /etc/resolv.conf
    2010/03/09 09:41:14| Adding nameserver 216.228.208.2 from /etc/resolv.conf
    2010/03/09 09:41:14| Adding nameserver 216.228.208.3 from /etc/resolv.conf
    2010/03/09 09:41:14| helperOpenServers: Starting 2 'python' processes
    2010/03/09 09:41:14| logfileOpen: opening log /dev/null
    2010/03/09 09:41:14| Unlinkd pipe opened on FD 18
    2010/03/09 09:41:14| Swap maxSize 104857600 + 262144 KB, estimated 8086134 objects
    2010/03/09 09:41:14| Target number of buckets: 404306
    2010/03/09 09:41:14| Using 524288 Store buckets
    2010/03/09 09:41:14| Max Mem  size: 262144 KB
    2010/03/09 09:41:14| Max Swap size: 104857600 KB
    2010/03/09 09:41:14| Store logging disabled
    2010/03/09 09:41:14| Rebuilding storage in /var/squid/cache (CLEAN)
    2010/03/09 09:41:14| Using Least Load store dir selection
    2010/03/09 09:41:14| Current Directory is /etc
    2010/03/09 09:41:14| Loaded Icons.
    2010/03/09 09:41:14| Accepting proxy HTTP connections at 192.168.0.25, port 3128, FD 19.
    2010/03/09 09:41:14| Accepting transparently proxied HTTP connections at 127.0.0.1, port 80, FD 20.
    2010/03/09 09:41:14| WCCP Disabled.
    2010/03/09 09:41:14| Configuring havp Parent havp/3121/0
    2010/03/09 09:41:14| Ready to serve requests.
    2010/03/09 09:41:15| Store rebuilding is 70.4% complete
    2010/03/09 09:41:15| Done reading /var/squid/cache swaplog (5816 entries)
    2010/03/09 09:41:15| Finished rebuilding storage from disk.
    2010/03/09 09:41:15|      5816 Entries scanned
    2010/03/09 09:41:15|         0 Invalid entries.
    2010/03/09 09:41:15|         0 With invalid flags.
    2010/03/09 09:41:15|      5816 Objects loaded.
    2010/03/09 09:41:15|         0 Objects expired.
    2010/03/09 09:41:15|         0 Objects cancelled.
    2010/03/09 09:41:15|         0 Duplicate URLs purged.
    2010/03/09 09:41:15|         0 Swapfile clashes avoided.
    2010/03/09 09:41:15|   Took 1.3 seconds (4500.4 objects/sec).
    2010/03/09 09:41:15| Beginning Validation Procedure
    2010/03/09 09:41:15|   Completed Validation Procedure
    2010/03/09 09:41:15|   Validated 5816 Entries
    2010/03/09 09:41:15|   store_swap_size = 445220k
    2010/03/09 09:41:16| storeLateRelease: released 0 objects
    


  • And when I add the lines to squid so it caches windows and avg updates the cpu goes into 100% as soon as I restart squid. Clean the lines out and restart squid and cpu drops back to normal.


Log in to reply