Can't do full install on soekris



  • Yeah, I know, there's better hardware vendors to support, but I didn't know it when I bought it  :P

    Anyway, I'm a happy 1.2.3-full user on a soekris net5501. I decided I needed 2.0, and at the same time use a new hdd instead of reusing the hdd that 1.2.3 is currently running on. I plugged the SATA hdd into my desktop, booted from the Live CD (2.0-BETA1-20100307-1553.iso.gz), and installed to hdd. Said hdd boots pfsense 2.0 fine on desktop.

    Then I placed the hdd in the net5501, replacing the old SATA hdd and connected to the console. It didn't get past the boot: prompt, "/boot/loader not found". I've tried a bunch of things at the boot prompt, like changing the default boot partition (0:ad(0,a)) to every possible value I could think of, but no dice. Entering simply "?" at the boot prompt lists the contents of my root directory, but I still haven't succeeded in making it boot.

    So in an effort to make my feedback more meaningful, I would like to pose a couple questions:

    1. Somebody must have done a full install of 2.0 from live CD and had it boot on a soekris box. Did you have to do anything out of default to get it to boot?

    2. Could I just have a bad build? I sort of doubt it, since it boots fine in my desktop hardware, but I'm kind of surprised not to have found a solution by now, even with some help from smart people on the mailing list. At some point I may try another build.



  • I think it's been done by others. There was some ATA issue but I thought that was possibly resolved in FreeBSD RELENG_8. Not sure, I have racks full of hardware, but no 55xx Soekris, so I have no way of trying.

    Might want to check the soekris-tech list for info on running a stock FreeBSD 8.0 or RELENG_8 (what will be 8.1). 2.0 is based on RELENG_8 at the moment. Or even info on running FreeBSD 7.x might be helpful.



  • http://www.soekris.com/support.htm

    My board is definitely subject to issue 0007, and I'm now suspecting 0008, so the board is going back to Cali for repairs. I suspect and hope that will resolve the problems I've been experiencing here.



  • Ah, that might be related. Post back and let us know what you find after it's fixed.



  • I have installed FreeBSD 8.0 on a Soekris net5501 with a SATA disk, and it runs like a charm.

    I have also installed pfSense 2.0-BETA1 (2010.03.08 01:34).
    This does not work too well, but the problems are related to the pfSense BETA1, not the Soekris net5501 or FreeBSD as such, as far as I can tell.

    What I did was:

    1. Set the console speed to 57600 in comBIOS.

    2. Updated /etc/fstab. On the Soekris net5501 the SATA disk is /dev/ad1

    3. Put this in /boot/loader.conf:
      console="comconsole"
      comconsole_speed="57600"

    This did the trick for me.

    You may also have to play around with /etc/ttys.
    I have tried many different settings, but much of the output is garbled, though kind-of usable.



  • Thank you for the pointers. I'm going to have another crack at this after getting my board updated.


Log in to reply