Squid slow on one site



  • Everything else seems to be working fine, but loading one site (aa.com) is very, very slow when going through Squid.  The page starts to load, then freezes for a couple of minutes, then finishes loading.  I've tried excluding that site from caching, but the only thing that works is turning Squid off.  Every other site I've tried works fine.

    Any ideas?



  • See approx line 1267 of /usr/local/pkg/squid.inc and add 144.9.72.134/32 to the list of non-redirected IPs  Worked for me as I just noticed we were having issues too.

    Better option is to fly Southwest.



  • Cool, thanks; I'll give it a try.

    Unfortunately it's management that's doing the flying, and they write the checks so I just salute and say, "I'll get right on it."



  • Well I tried that, restarted Squid, and it's still doing the same thing.  I changed that line to:

    $rules .= "no rdr on $iface proto tcp from any to { 192.168.0.0/16, 172.16.0.0/12, 10.0.0.0/8, 144.9.72.134/32 } port 80\n";

    But still no joy.  It loads the very top of the page, then takes about 2-3 minutes to load the rest.



  • Try clicking save in the Squid GUI - this should reload the filters.  Restarting the service might not do this.



  • I realized after posting what I'd done.  In fiddling around with various settings, trying to figure out what was going on, I had unchecked the 'Bypass proxy for Private Address Space (RFC 1918) destination' setting.  Ticking that setting and making the above edit to Squid.inc.  Thanks!


Log in to reply