Http traffic causing ping spikes, need to give gaming ultimate priority



  • i have a 6/.5 connection with 1-2 other people using it. They mostly just browse the web, facebook, youtube, etc. That seems to be enough to cause spikes in my Quakelive ping. I want to make it so quakelive gets the ultimate priority. I don't care if everything else is crawling. i want to take the most extreme measures to ensure that i get no spikes, while still having the internet usable for other people (usable = pages will load as if on a 56k connection).

    My setup is really simple.. its just ports 27960-27999 that need top priority.. low latency/no delay, presidential escort. as i said, its mostly http traffic that i'm competing with. P2P isn't really even a big issue.

    Right now i have the results of the wizard setup, where the only thing checked was optimize for gaming and quake3 (same as quakelive). that doesn't seem to be working.

    thanks in advance for any help.



  • If your upload parent queue is set to high your QoS is useless. Double-check your filters and if they look good try setting your parent queue really low, like 250kbit. If that works you can try eeking up that number until you find the magic spot, which is the highest possible number without gaming lag.



  • @clarknova:

    If your upload parent queue is set to high your QoS is useless. Double-check your filters and if they look good try setting your parent queue really low, like 250kbit. If that works you can try eeking up that number until you find the magic spot, which is the highest possible number without gaming lag.

    Can you explain that a bit deeper? I'm dealing with the same issue (HTTP traffic causing ping spikes in gaming) and I didn't quite understand what you just said. I tried to look for a setting like the one you mentioned, but I can't find it.



  • @matte3560:

    @clarknova:

    If your upload parent queue is set to high your QoS is useless. Double-check your filters and if they look good try setting your parent queue really low, like 250kbit. If that works you can try eeking up that number until you find the magic spot, which is the highest possible number without gaming lag.

    Can you explain that a bit deeper? I'm dealing with the same issue (HTTP traffic causing ping spikes in gaming) and I didn't quite understand what you just said. I tried to look for a setting like the one you mentioned, but I can't find it.

    Meaning that your qWANroot's bandwidth must be set correctly. If set too high it becomes useless. For cable / adsl links, cutting off about 100 - 200 kbps from advertised uplink bandwidth would give you the correct result. So, try with 200 kbps cut-off first.



  • The Linux Advanced Routing and Traffic Control HOWTO is the best reference I've found yet for the principles of traffic shaping. Try this section in particular for the explanation you're asking for:

    http://lartc.org/lartc.html#AEN691


Log in to reply