Upgrade destroys user changes



  • In order to get pfSense 2.0-BETA1 to boot on a Soekris net5501, I had to do manual changes to the following files:
    /etc/fstab
    /etc/ttys
    /boot/loader.conf

    When upgrading, fstab is left alone, but the two other files are overwritten, and the system is bricked.

    May I suggest that on update those files are left alone, or that user changes are merged with the new update.



  • I've noticed my loader.conf gets overwritten everytime on upgrade to the latest snapshot as well.


  • Rebel Alliance Developer Netgate

    Are you doing a full install or nanobsd? Sounds like a full install.

    Have you tried just enabling the serial console from the GUI? If that doesn't work, please post what changes you had to make to /etc/ttys

    As for loader.conf, I had thought that was left alone now. Either way, you should be able to use loader.conf.local which should stay.



  • Yes, I am using full install.

    I tried to edit loader.conf.local but it still overwrote it. Here are the changes I made to get serial and vidconsole.

    loader.conf

    console="comconsole,vidconsole"
    comconsole_speed="115200"
    
    

    /etc/ttys

    console	"/usr/libexec/getty Pc"	        cons25	on secure
    

    I could try to enable terminal in the webgui but it is fixed to 9600 and it is missing vidconsole just incase I need to access at the physical box.


  • Rebel Alliance Developer Netgate

    Hmm, well loader.conf and loader.conf.local should be removed from new snapshots. I'll have to look at it again tomorrow to check since the snapshots were broken most of the day today.


Locked