Decision: Watchguard Firebox II & Pfsense don't play together



  • Ok, after many weeks of trying to get Pfsense running on a WG FIrebox II, I have come to the conclusion that it will simply not work. I've tried every release i can find, I've tried CF/microdrive/2.5" HDD. I've tried every hint and doco I could "google". But it refuses to do work, (read boot). What's got me stumped is that m0n0wall works fine…

    So, the decision is that Pfsense doesn't work, and I'll have to go back to m0n0wall.    :'(



  • At least 1 member, hammaskejju, has gotten it to work on his WG II (see: http://forum.pfsense.org/index.php/topic,17645.0.html ), so apparently pfsense does 'work'. It is also mentioned here (as well as the FB III): http://forum.pfsense.org/index.php/topic,21523.0.html

    Maybe you would have better luck specifically asking the people who run similar configurations about whether they have encountered the same issues. You may also try to be more detailed in the description of what you have done. Statements like "I've tried to install pfsense in every way I know how" doesn't help anyone to understand what you did since we don't know how much you know. Every OS is going to have issues when it's installed on unusual platforms, so abandoning the OS with parting comments like 'doesn't work, adios' will eventually leave you with one conclusion: the stock OS. In your case that would be Watchguard's.



  • Sorry, I posted this at bed time…

    Ok, to expand on your post....
    I've read the forum links and asked for assitance from the posters - thankyou for the link too... :)

    I have a WG FBII that has been upgraded to a AMDk6-200 with 512Mg Ram. I have the proper cable for a CF card adpater and different sizes of CF cards, (1G & up). I've also got different sizes of laptop 2.5" HDD's. I've tried the embedded images going back as far as 1.2 all the way up to 1.2.3 nanobsd versions. I've written them all with the "physdiskwrite" application both through the command line and the gui. I've used a USB card reader to write the images, I've also used the CD installer and put the CF card into the adapter and installed it into the laptop as a HDD and installed this way, selecting the embedded kernel at the finish - boots fine except only 1 NIC.

    I have tried and followed the "NanoBSD on WRAP" link and all the other documents that I can come across, but I can't seem to get it to go. I've worked with various flavours of *nix for the last 10 or so years, so I'm not afriad to get in and play..

    The end result is that the FBII won't boot. It comes up with an option of "F1 FreeBSD" and "F5 Drive 0" and then proceeds to show a line of ### forever. Every push of a key on the keyboard results in more ###'s.

    Thanks for your direction and my apologies for the first post.
    Regards
    Karl


Log in to reply