Pfsense reboots itself



  • Hi guys,
    I hope someone can help with this issue as I tried everything and it doesn't work.
    I used this hardware for couple years and it worked fine:
    http://linitx.com/viewproduct.php?prodid=11424
    I used version 1.0.1 on CF card.

    Unfortunately the power supply died and I needed to replace it and I thought it will be good idea to install the latest version of pfsesne (pfsense 1.2.3). Also I decided to install SATA drive instead of CF card flash card. I haven't got any problem with the installation and I didn't notice any errors on the console, so I put this back into live environment. Unfortunately it's rebooting itself randomly. As I didn't use this version at all I'm wondering if there are some bugs in this version. Also it might be SATA drive issue.
    I found these logs about fsck run:
    ad4: 76293MB <maxtor 6y080m0="" yar51hw0="">at ata2-master SATA150
    Trying to mount root from ufs:/dev/ad4s1a
    WARNING: / was not properly dismounted
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck</maxtor>

    I've got other installation (pfsense 1.2.2) which is running on dell pc with IDE drive and I haven't got any problems for years.
    I will appreciate for any help and suggestion.


  • Rebel Alliance Developer Netgate

    "Random" reboots are almost always hardware related in some way. With so many things changed at once it is hard to say what it might be, but the top suspects with such random hardware issues are RAM, PSU, overheating/lack of cooling, HDD, cabling, mb/psu, and so on.

    There is probably no good way to really know for sure without trying different components or running hardware diagnostics (though they are not always reliable. If they find a problem, there is a problem, but sometimes problems aren't found…)



  • the fsck messages are only because the system rebooted without unmounting the filesystems, so they are unclean and need to be checked.  agree with jimp about likely causes.  one easy test: download memtest86, burn to an CDROM and test your memory.  if that is clean, less easy to check other things.



  • Right, I swapped from hard disk to compact flash. It was fine when I watched it in data centre. Unfortunately I get back to office and it started again. The difference between old box and new one is just memory now but I can't test it at the moment. The memory what I installed is compatible with motherboard - I checked 2 times. Anyway I noticed some kind of frequency in rebooting. It's happening every 1h and 40 minutes… so I've checked the crontab if there aren't any jobs. Nothing is there.
    Also I can't find anything interesting in the logs, so probably I need to change the memory. But like I said that time between reboots is really interesting (approximately 100 minutes). Has anyone got something similar?



  • Until you test the memory, you can't really rule it out.  Sullrich was kind enough to point that out to me on Twitter, and he was right.  A module that I had tested not more than 6 months ago had gone bad, and I swapped it out for another stick, albeit slower, but pfsense isn't really bandwidth hungry on memory, so it worked out in the end.



  • Could this be a VIA padlock issue?



  • Hi guys,
    I didn't leave any notes as my firewalls are working fine at the moment - it's about 50 days now without reboot.

    I thought to change the memory but I gave up as it didn't reboot for 2 days and now it's running smoothly for almost 2 months…


Locked