NMap installation failed



  • Trying to install NMap I have:

    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading nmap and its dependencies... done.
    Checking for successful package installation... failed!
    
    Installation aborted.
    

    And the pakage isn't installed…
    In the log I have:

    php: /pkg_mgr_install.php: Beginning package installation for nmap.
    

    What's wrong?



  • I'm having the same issues.  I had it on 0.95 and now on 0.95.4.



  • Thanks for the heads up - I'll take a look at nmap this evening.



  • Any news?  ???



  • @Emab:

    Any news?  ???

    Try again in 5 minutes.



  • @sullrich:

    @Emab:

    Any news?  ???

    Try again in 5 minutes.

    Still not running…



  • NMap is currently not running even with 0.95.8



  • This is now fixed.



  • @sullrich:

    This is now fixed.

    Now I can install it, but it's not running.
    If I do scan I obtain this page:

    	"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    
    	<title>befirewall.local - Diagnostics: NMap</title>
    
    				webConfigurator
    
    						befirewall.local					
    
    *   System
    
        *   [Advanced](/system_advanced.php)
    
        *   [Firmware](/system_firmware_check.php)
    
        *   [General Setup](/system.php)
    
        *   [Packages](/pkg_mgr.php)
    
        *   [Static routes](/system_routes.php)
    
    *   Interfaces
    
        *   [(assign)](/interfaces_assign.php)
    
        *   [WAN](/interfaces_wan.php)
    
        *   [LAN](/interfaces_lan.php)
    
        *   [OPT1](/interfaces_opt.php?index=1)
    
    *   Firewall
    
        *   [Aliases](/firewall_aliases.php)
    
        *   [NAT](/firewall_nat.php)
    
        *   [Rules](/firewall_rules.php)
    
        *   [Traffic Shaper](/firewall_shaper.php)
    
        *   [Virtual IPs](/firewall_virtual_ip.php)
    
    *   Services
    
        *   [Captive portal](/services_captiveportal.php)
    
        *   [DNS forwarder](/services_dnsmasq.php)
    
        *   [DHCP relay](/services_dhcp_relay.php)
    
        *   [DHCP server](/services_dhcp.php)
    
        *   [Dynamic DNS](/services_dyndns.php)
    
        *   [Load Balancer](/load_balancer_pool.php)
    
        *   [SNMP](/services_snmp.php)
    
        *   [Wake on LAN](/services_wol.php)
    
    *   VPN
    
        *   [IPsec](/vpn_ipsec.php)
    
        *   [PPTP](/vpn_pptp.php)
    
        *   [PPPoE](/vpn_pppoe.php)
    
    *   Status
    
        *   [CARP (failover)](/carp_status.php)
    
        *   [DHCP leases](/diag_dhcp_leases.php)
    
        *   [Interfaces](/status_interfaces.php)
    
        *   [IPsec](/diag_ipsec_sad.php)
    
        *   [Package logs](/diag_pkglogs.php)
    
        *   [Queues](/status_queues.php)
    
        *   [Services](/status_services.php)
    
        *   [System](/index.php)
    
        *   [System logs](/diag_logs.php)
    
        *   [Traffic graph](/status_graph.php)
    
    *   Diagnostics
    
        *   [ARP Tables](/diag_arp.php)
    
        *   [Backup/Restore](/diag_backup.php)
    
        *   [Command Prompt](/exec.php)
    
        *   [Edit File](/edit.php)
    
        *   [Factory defaults](/diag_defaults.php) 
    
        *   [Halt system](/halt.php)
    
        *   [Ping](/diag_ping.php)
    
        *   [Reboot system](/reboot.php)
    
        *   [States](/diag_dump_states.php)
    
        *   [Traceroute](/diag_traceroute.php)
    
        *   [NMap](/pkg.php?xml=nmap.xml )
    
    Diagnostics: NMap
    
    


  • Visit Diagnostics -> NMap



  • @sullrich:

    Visit Diagnostics -> NMap

    Yes, I do that.
    I go in Diagnostic
    NMap.
    insert a valid IP.
    TCP scan.
    Scan.

    And I obtain the above blank page.



  • @Emab:

    @sullrich:

    Visit Diagnostics -> NMap

    Yes, I do that.
    I go in Diagnostic
    NMap.
    insert a valid IP.
    TCP scan.
    Scan.

    And I obtain the above blank page.

    Hello I have the same issue… in 0.96.4 version
    any ideas?



  • Then I click nmap from the packages page (to install it) it opens a new blank window.  Nothing else happens.



  • It appears that we're missing a few libraries in base that nmap requires, which is why a blank page is being produced. I'll talk to Scott and see if we can get the necessary libs back in.



  • As of nmap 3.91 they require updated versions of libpcap and libpcre which is probably where the breakage is happening.  I almost wonder if it wouldn't ultimately be easier for the pfSense package maintainer to compile their own binary packages so that breakages like this don't become commonplace.  I realize this is a little OT, but some software gets updated almost weekly and generates really ugly error messages in the logs if you aren't running the latest and greatest (clamav comes to mind).  Unless there's going to be a clever way for pfSense to keep its package tree up to date easily, this might quickly get out of hand.  Please note, when I'm referring to binary packages I'm referring to FreeBSD packages, not pfSense packages.

    I know that Colin is already hard at work creating new packaging guidelines and documentation, so when I see them this whole discussion may be completely pointless and moot.  If not, then it might be something to consider.



  • NMAP has been marked as broken.  We'll get back to it later on.


Log in to reply