Used Traffic Shaping wizard and all traffic goes to "qlandef"



  • I ran the wizard for traffic shaping for VOIP and P2P BitTorrent. When viewing the queues nothing ever goes in the VOIP queues or P2PBitTorrent Queues, All the traffic goes to the qlandef queue. Anyone know why this would be or how to troubleshoot?

    Running 1.2.3 embedded on an alix 2d3

    My voip is through Lingo and I have a static IP for the adapter that I have plugged into the VOIP section during the wizard. Also my port for BitTorrent is 6881 and matches what is in the wizard by default for the port.

    Thanks in advance

    Jon



  • I am confused.  qlandef is for incoming traffic - it is extremely unlikely that there will be any non-default QoS tags on those packets.  As far as outgoing VOIP, STF for this - if your ATA sets any kind of QoS bits for priority, they will be put in the qwanacks queue (that is just how it works.)  I worked around that by setting the SIP and RTP QoS to zero in my VOIP host.



  • @danswartz:

    I am confused.  qlandef is for incoming traffic - it is extremely unlikely that there will be any non-default QoS tags on those packets.  As far as outgoing VOIP, STF for this - if your ATA sets any kind of QoS bits for priority, they will be put in the qwanacks queue (that is just how it works.)  I worked around that by setting the SIP and RTP QoS to zero in my VOIP host.

    It was both qlandef and qwandef

    It is true that my viop provider (Lingo) sets QoS for both incoming and outgoing (I assume). What I tried, and you guys tell me if this will adversly affect anthing else is as follows:

    My VoIP ATA IP is 192.168.79.109 (Set statically behing the pfsense)
    I ran the traffic shaping wizard and only selected VoIP with setting the IP in the wizard to 192.168.79.109
    If I just do this all VoIP traffic will go to qlandef and qwandef

    However if I edit the VoIP up and down queue and check off the ACK checkbox and then view the queues all VoIP traffic goes to the VoIP queues and it looks like thats all that goes there. All seems fine but I am afrain that it shouldnt be that easy and that its affecting something else or not right

    I ran a speed test while my wife was on the phone a few times and watched the queues and the VoIP queues stayed a constant 85K and she said that she had no "breakups"

    So, can anyone give me the final verdict? Is it right to do it the way that I did it?

    Thanks
    Jon



  • that is weird.  qwanacks and qlanacks do not have the ACK flag set too?  they should by default.  If you set the voip IP address correctly, i am surprised it did not work until you set the ACK flag.  note that even if lingo sets QoS for inbound packets, they will almost certainly not be honored by anyone between them and you, so that is not really going to matter.



  • yes right now qwanacks and qlanacks have the ACK checked of as well as both VOIP queues



  • yes I had the IP set and it didnt go to the voip queue till i checked off the ACK box…weird


Log in to reply