Axe & altq not supported? (PFSense 1.0)



  • Hi,

    I am using PFSense 1.0 with a NetGear FA120 (ASIX) USB/Ethernet adaptor (axe0) and a 3COM 10/100 NIC (xl0).  When trying to get PFSense to run with axe0, I get an error message saying "altq is not supported by axe0 driver".  Can anyone shed some light on WHY the axe driver would have issues with ALTQ?  Googling didn't turn up anything useful.

    I have tried making axe0 WAN or LAN, both cases I got the same error message and pfsense would not route from LAN to WAN, though in either case I could ping from the pfsense machine out and I could access pfsense via the web interface.

    On the same hardware, I was able to get the machine to work with another non-axe Ethernet NIC, but that is borrowed so getting axe working is my first choice.

    Thanks!
    dc0



  • The driver has to support altq and the axedriver simply doesn't. See http://forum.pfsense.org/index.php/topic,16.msg35.html#msg35 for a list of compatible drivers. With this nic you can't do trafficshaping but it will be fine when using without trafficshaping (besides that usb is pretty slow and might cause some other issues; freebsd's usb support is not that great atm).


Log in to reply