Rt2860/2870 wireless support



  • Greetings.

    I installed the BETA the other day on my netbook (eeepc 901) hoping to use it as my gateway.
    The thing is that the wireless card is ralink 2860, that is not supported by the ral(4). There is a fanmade(?) driver in the freebsd forums that works on 7.2 and 8.0, so i thought i should give it a shot.
    I built the .ko target in a vm and scp'ed it to /boot/kernel/ in pfsense. The driver worked almost perfectly (after messing with /etc/inc/globals.inc to add rt2860 in the wireless_regex section). I managed to run hostapd in 802.11ng mode, even though there were some errors reported in Status>Interfaces.

    The problem now:
    every time i update the firmware, the changes i made are reverted (this is the point of the update after all, update the system files).
    Is there a way to specify that during the update /boot/kernel/rt2860.ko and /etc/inc/globals.inc are to remain the same?

    Thanks in advance.



  • Can you link here the patch for the new driver.
    Maybe it can be included in our builds.



  • @ermal:

    Can you link here the patch for the new driver.

    it's actually an other driver rather than a patch of ral(4).
    Anyhow, http://repo.or.cz/w/ralink_drivers.git it the whole repo.
    This is the 2860 for pfsense's builds and this is the 2870. It's also backported to 7.2 if anyone is interested for the stable version of pfsense.

    The instructions and the updates are announced in this thread



  • Hello,
    I used rt2860 freebsd7.2 driver with pfSense1.2.3, works perfectly.
    After that i tried pfSense2.0Beta with rt2860 freebsd8 driver.

    In this case I got the following problem.

    • the driver works fine in freebsd8 (activated it with wlandev by ifconfig)

    • now pfSense identificates the driver als wlan-interface and all works fine

    • to get this driver to run in pfSense on autostart I added <wireless>to the interface in config.xml manually

    • after a restart pfSense creates a wlandev automatically from this driver

    • if I activate this interface I get a kernel panic and have to reinstall pfSense
      Where is the Problem? What is the difference between activating the driver in pfSense and FreeBSD?

    (sorry about my english)

    Best regards
    Alex</wireless>



  • If the driver uses a new name, you might need to add it to wireless_regex in /etc/inc/globals.inc.



  • @Efonne:

    If the driver uses a new name, you might need to add it to wireless_regex in /etc/inc/globals.inc.

    exactly. the name is rt2860



  • I mean the name of the driver, which determines what the interface will be called on the system.  For example, devices using the ath driver for Atheros cards will be ath0, ath1, etc.  Were you saying the driver itself is called rt2860?

    Hmm, just looked at the thread you linked to.  It looks like it ends up with an oddly-named device. :)  I'm guessing it would be given a name that does not end in a number if it is later included in FreeBSD.  Anyway, if rt2860 is the name, that is what you would add to wireless_regex.



  • yes, rt2860 is the driver's name. the devices are named rt28600, rt28601 etc…



  • nice tip (wireless_regex),

    now the wirelesscard starts automatically with pfsense.

    when i activate the interface, the card changes in promicous-mode, all seems good.. but in this moment i try to connect with a wlan-client a kernel panic happens.

    ok it seems that isn't a real pfsense problem… got also kernel panic by activating it directly with ifconfig...

    could it be because of the src and base distributions of freebsd 8.0-RELEASE?
    couldn't find them for 8.0-stable...

    have the problem with the shell... i always have to install 1.2.2 dev to have a shell and sysinstall... then after installation sys and base for 8.0-RELEASE i upgrade to 2.0beta.. so i keep the shell and the sysinstall and have the possibility to compile the driver...

    are there any better workarounds?



  • Looks like (http://forums.freebsd.org/showthread.php?t=7010&page=13) that this driver is working now. Any chance it might be able to be shipped in pfsense firmware by default instead of needing to be fussed with?


  • Rebel Alliance Developer Netgate

    It might be possible. I'm not sure what issues might be caused by their wacky choice of device name though.

    I didn't think it was generally allowed to have a number as a part of the device name like that (when it is part of the name, and not a probed device number).



  • I would love to see this driver included in 2. The Edimax USB NIC I’m using is the only one at a decent price with a removable antenna i could find!

    It would also mean i could get rid of my old 802.11g access point save some power and get better bandwidth, and all the pfsense wireless features.

    Might give building the module a go on a VM and copying it over not sure if I will get very far tho! Does’ anyone have a prebuilt module for the 2870 & pfsense beta 2?



  • First you have to rename the module to not use those numbers in the name :).


  • Rebel Alliance Developer Netgate

    +1 to what ermal said. They need to choose a better name for that driver, one that adheres to proper conventions for device naming, which doesn't include using numbers in the device name.



  • Ive not yet built it! Only got as far as writing the BSD 8.1 image to a USB pen drive. Work tommorow :) Thanks though will rename it if I get that far.



  • Just to elaborate: the rename involves a source code change in the driver rather than a file rename.

    It may also be of interest that the FreeBSD run driver MIGHT support your device. It supports a number of the newer Ralink USB devices. See http://forum.pfsense.org/index.php/topic,27744.0.html for a little more information.


  • Rebel Alliance Developer Netgate

    There isn't a build with the new kernels yet, so keep an eye out for the next new snapshot and give that a try to see if run(4) will work for you.



  • Ah changing the source code is out of my depth. I guess I will wait and hope its included.



  • any news on this one ?

    2860 drivers are avaliable here:

    http://repo.or.cz/w/ralink_drivers.git



  • Just curious if there are any updates?!

    Gabriel


  • Rebel Alliance Developer Netgate

    If it doesn't work with the run/rum drivers, it isn't likely to be in 2.0.



  • Thanks jimp and here's to hoping it will!

    Gabriel


Locked