Net5501 sata HD failed boot - problem with dma speed?



  • Hi guys,

    I'm having a problem with my net5501 soekris board. I'm using 1.2.3 pfsense release on it with:
    http://soekris.eu/shop/accessories/hd_momentus54004_160gb_sata_en.html
    sata HD.

    I have installed the image from the boot cd on my laptop and put in the box after but I have a problem booting pfsense from the soekris.

    Sometimes boot will not start cause the system is not seeing HD on the startup. I'm suspecting that my board may have issue 0008. according to support site of soekris:
    http://www.soekris.com/support.htm

    I knew I saw somewhere on this forum and soekris website issue with the board about wrong dma speeds bios will assign to a HD but I don't know if what I see in the console is a sign of just this… It's a short command forcing dma66 but I can't find it anywhere when I need it. I was seeing when browsing the forum but can't find it anymore.

    Here is what console shows on a failed boot:


    POST: 012345689bcefghips1234ajklnopqr,,,tvwxy

    comBIOS ver. 1.33  20070103  Copyright (C) 2000-2007 Soekris Engineering.

    net5501

    0512 Mbyte Memory                        CPU Geode LX 500 Mhz

    Pri Sla  ST9160314AS                    LBA Xlt 1024-255-63  134 Gbyte

    Slot  Vend Dev  ClassRev Cmd  Stat CL LT HT  Base1    Base2  Int

    0:01:2 1022 2082 10100000 0006 0220 08 00 00 A0000000 00000000 10
    0:06:0 1106 3053 02000096 0117 0210 08 40 00 0000E101 A0004000 11
    0:07:0 1106 3053 02000096 0117 0210 08 40 00 0000E201 A0004100 05
    0:08:0 1106 3053 02000096 0117 0210 08 40 00 0000E301 A0004200 09
    0:09:0 1106 3053 02000096 0117 0210 08 40 00 0000E401 A0004300 12
    0:14:0 13A3 0020 0B400000 0116 0280 08 40 00 A0005000 A0006000 10
    0:20:0 1022 2090 06010003 0009 02A0 08 40 80 00006001 00006101
    0:20:2 1022 209A 01018001 0005 02A0 08 00 00 00000000 00000000
    0:21:0 1022 2094 0C031002 0006 0230 08 00 80 A0010000 00000000 15
    0:21:1 1022 2095 0C032002 0006 0230 08 00 00 A0011000 00000000 15

    1 Seconds to automatic boot.  Press Ctrl-P for entering Monitor.
    þþàæþþþ~øøæàæþøøxx~æx~``fæþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàþþææàffàøxxæfxxæxææfxøæxfæfxøæøæfxàø~xàà~fxàxæfxàxæfxàæ~fæfxàøæfxàøxàæfxàøxxfxx~xx~xxxxxxfæfxxfæxxxþxx~xxæfxxxfæfxxøàæfxxàæxxæfxxøæfxxøxxxfxfxxxfxx~øæfxxøfxxxøæfxøfxfæfxxfxæfxfæxxæfx~ø~x~fxfxæfxàxàæfxxfxxæxffxæfxxxxæfxøfxø~xà~fæfxààfxàxæfxàx~xà~fxàææfxàæøæfxàøfxàxxàøxxxæøæfxxøæææfxxæfxxfxààæfxfffæffxføøææfàææfààæàxffàxæxàxfàæxfàxxfààøææfxfxæfx~x~æfxfxfxxæfx~àæfxàxfæfxfxæfxfxxfxæxfæfxxøfæfx~øæfàæ~àæ~ààxæfxæfxøfxfxææfææf```þøàæxààxfàxàxfààæfàæàæàþàæfà~æfàøø~x~æfxøfæfxæfxfx``xfþxxæfx~xxxfæfxøæfxøxfxæfxfxx~xf~xxæøæfx~øffàfàfàfààxæfxøf~ææàæføfæàæføààæfàààx`æfàxøfx`àfx`àææfàææfààþffàøfxfxxþffxfæfxxxfxffxxfxx~xæfxøfxxæffxfàfxàxfxxffxxxþffx~føæfxøxæfæfæøæføæfxfxæfxøfx~æføfxææàþæxæfæxøæxæxàææfææfæf~æææøf```fæfæàæfàfffxf~xxfxf~fxff~f``ffxæf~ææffffx~àxf~xf~xøf~øf~æf~àø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààæfø~xæfø~àþø~xø~àæø~xfø~ààffø~xffø~ààø~xþø~xæfø~xø~æxø~ø~~æfø~xfø~øø~æfø~ààæø~xþø~xæfø~~þø~ææfø~xfæfø~xø~xæfø~øf~ø~æø~àæfø~x~æfø~xøæø~àø~æþø~æfø~xø~xfæfø~øøæfø~øø~àæfø~xàæø~xøø~xæfø~æxfø~fø~àf~ààæfà~xæfà~àþf~xf~àæf~xfà~ààffà~xffà~ààæfà~xæfà~àþf~xf~àæf~xfà~ààffà~xffà~ààæfà~xæfà~àþf~xf~àæf~xfà~ààffà~xffà~ààæfà~xæfà~àþf~xf~àæ`f~xfà~ààfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæàfàþæ


    Any help would be greatly appreciated!



  • That looks like you have your serial console at the wrong speed for the OS. Should be 9600. It's best to change the BIOS so it uses that as well and they're the same.


Log in to reply