Can go through to internet but can't access web config.



  • I've been running PFSense for about 4 months now and everything is working fine.  As far as I know nothing has changed on the box (I haven't done any updates or made any config changes lately) the system is 1.2.3, however suddenly I can't access the web configurator.

    I'm able to ping and ssh into the box, I'm passing 'net traffic through it since I'm able to type this message, and I've tried restarting the web configurator as well as rebooting the box all to no avail.

    LAN address is 192.168.1.1 I've tried http and https for accessing.  At this point I'm looking for 1 of 2 things:

    1. A way to get back into the configurator and return to normal

    or

    2.  A way to save the configurations I have created so that I don't have to redo everything if I have to rebuild the router to fix whatever went wrong.

    Obviously I'd prefer #1 but I'd settle for #2.  This is a home router and I don't have an immediate need to change anything up, but may in the relatively near future so would like to get this taken care of.



  • Please elaborate on "I can't access the web configurator". What happens when you try to access the configurator?

    Perhaps there is a configuration file error and the configurator is exiting on startup.



  • i am having the exact problem. I was trying to uninstall snort (as it did not seem to be updating the rules) with the intention of re-installing snort after I rebooted. I am unable to use the webconfiguator .

    during boot…

    it says... starting webconfiguartor ... failed!

    I have tried to use option 11) restart webconfigurator
    I reset the default password as well.....

    trying to access it via firefox 192.169.X.X just times out.

    I have a backup of the config file sitting on another computer doh! any way to restore from the shell via a USB drive??



  • just a follow up..

    I tried this
    http://forum.pfsense.org/index.php/topic,10409.0.html

    then

    http://forum.pfsense.org/index.php/topic,6998.msg49266.html#msg49266

    seemed to load the config.xml file, upon reboot webconfigurator failed again? (NFI) probably missed a step

    resolve, just did a re-install from CD…. which fixed the web configurator problem, then restored from the same back up.... seems to be working again... one strange thing was during re-install of packages.. snort was reinstalled, then removed then reinstalled? (is it possible to have installed twice by mistake?) I only say that as it went through the 5% 10%...100% routine twice as I went a made a coffee and came back to find the message "removing snort" then installING snort 5%..%100.... no biggie!


Locked