Squid access denied from Allowed subnet?



  • Hi, I would like to setup HAVP+squid+squidguard in transparent mode. For the time being I just setup a basic configuration:

    Internet <–> HAVP <--> squid <--> LAN

    I setup squid in transparent mode but currently it's not working. Setting up a client to explicitly use the proxy listening on port 3128 I get a 403 access denied, even though the client is supposed to be allowed.

    The client has IP 10.10.2.100 and the allowed subnets are setup like this:

    10.10.1.0/24
    10.10.2.0/24
    10.10.3.0/24

    Any ideas?



  • Try tinkering with the box on the front page of the Squid/Proxy GUI called 'Allow users on interface'.  This has, in the past, overridden the allowed subnets box you are using.  Tick it, save, test, untick, save, test.  Hope it helps.


Log in to reply