Strange problem with Squid (pfSense_Lusca packages by Chudy)



  • After install and configure the package (pfSense Lusca) in pfSense 1.2.2 I discover that,

    non-Transparent   =>   Browser with Manual Proxy (3128)   =>   Internet Surfing OK
    non-Transparent   =>   Browser with no Proxy (direct)   =>   Internet Surfing OK

    Transparent   => Browser with Manual Proxy (3128)   =>   Internet Surfing OK
    Transparent   => Browser with no Proxy (direct)   =>   No Internet Connection (Connecting to www…....)

    the only way I can make Transparent mode running is to add a Rules in firewall,

    Proto     Source     Port     Destination       Port         Gateway     Schedule     Description
    TCP      LAN Net      *        127.0.0.1     80 (HTTP)          *

    Last time when I was using Squid 2.7.7 packages it wasn't necessary to do this.

    1. Is it a bug in pfSense Lusca packages?
      2. Is it OK for me to just continue using the above setting?



  • check enable transparent proxy at webgui,

    check at console :

    pfctl -sn |grep http

    and check :

    squidclient -p port-squid cache_object://your-ip-squid-box/config |grep transparent



  • how to check if the Lusca package works perfectly? i just see url changes in proxy report..



  • use squidclient command
    e.g @ console type
    #squidclient -p 3128 cache_object://localhost/info
    you can change 3128 with your squid listen port and localhost with your proxy ip

    or
    use only squidclient mgr:info

    http://forum.pfsense.org/index.php/topic,19251.msg124919.html#msg124919


Log in to reply