Out of swap space



  • Hi all

    I've been running pfsense 1.0 rc2e on P4 512 MB + 20 Gb HD with quite success. I've noticed that the CPU load is quite high : ~50% to 80%. The main usage is captive portal for wifi access with radius authentification.

    So i've tried to install pfsense 1.0 on a computer HP DX5150 (Athlon 64 2.0 Ghz + 512 Mo RAM + 80 Gb HD SATA). But on this platfrom, I had error plenty messages on the console (sorry, I don't remind then exactly because I was wondering how to reduce the downtime size) : outOfswapspace and the hdd seems to be very busy.

    I've tried to reformat and reinstall from scratch but this append again.

    Has anyone got these symptoms ?
    Could it be the athlon 64, or the shared ram with video (real available ram is 446 MB) ?

    Thanks to your help.

    Vincent



  • What services are you running on that box? 446 MB should be plenty of ram to not have problems. What size of swap partition did you create with the installer?



  • It's a fresh and basic install of pfsense with no extra packages.

    Concerning the size of swap partiotion, I left the default size which was 1024 Mo.

    Thanks for your help

    Vincent



  • @vd:

    It's a fresh and basic install of pfsense with no extra packages.

    Concerning the size of swap partiotion, I left the default size which was 1024 Mo.

    Thanks for your help

    Vincent

    When this happens, please run top from a shell and post the complete output if possible.



  • Hi

    I've not been unable to reproduce these errors since the last time.
    Unfortunatly, this morning, I got these errors. I couldn't access the pfsense via ssh.
    I saw error messages at the boot time at the console :
    swap_pager_getswapspace(<random number="">): failed  - plenty of this message
    swap_pager: out of swap space - once or twice.

    These messages came when it was displaying :
    starting /usr/local/etc/rc.d/*.sh… done (twice)

    On the webconfigurator, i saw a message : pfsense requires at lesat 128 mb of ram.
    I don't understand why pfsense is displaying such a message because I've got 512 Mb of RAM.

    Thanks in advance for you help

    Vincent</random>



  • We need the dmesg output from your machine (/var/log/dmesg.boot) to see if FreeBSD saw all your memory - you may have a buggy BIOS that doesn't report all the RAM to FreeBSD.

    –Bill



  • Hi

    I finally manage to send a file from pfsense to my workstation (win xp).
    Please find enclosed the dmseg.boot file.

    I don't understand anything at all. This time, my quantity of memory seems to be fully recognised but I haven't changed anything and for about 10 reboot before, only 128 Mb were recognised.

    Have you any idea ?
    Should I change of computer ? memory ?

    Thanks for your help.

    Vincent

    dmesg.boot.txt



  • Maybe some flaky memory that didn't get recognized by BIOS in the boot that pfSense also saw only 128M.  Not sure…I have seen wierd stuff like that on machines in the past (well before pfSense was born, so completely unrelated).

    --Bill



  • i had this problem too.Sometime when i reboot the machine i see a lot o lines like "get swap space" and nothing is not recognized as command.Icannot access via web interface or via ssh.I have reply from the machine but still nothing.The only way to turn up is to power off and power on again.I think that is something  that goes wrong at the boot start.



  • Swap with another RAM stick and check again.

    Damaged RAM produces really crazy errors. It happens to me at least once a month. Its worth a try.

    -G



  • Thanks GBelanger.
    I've tried to change the ram stick for one 512 Mb stick and now I don't get each time i reboot the box.

    I've noticed something and I don't know if it can help.
    I've noticed that when I reboot the box just at the time it's under heavy load (cpu usage about 90 to 100%), the reboot is quite longer : it's quite long at the time it should display :
    starting /usr/local/etc/rc.d/*.sh… done (twice)

    And often, I get messages about out of swap space just instead of the normal display.

    Hope this can help.

    Thanks

    Vincent


Locked