Captive Portal still error



  • pfSense 2.0 snapshot for April 15, is still problematic for captive portal, is there any solution …???



  • Just add a firewall rule to allow port 80 from any to any TCP and it will work out.



  • @ermal:

    Just add a firewall rule to allow port 80 from any to any TCP and it will work out.

    I Get some errors again in snapshot 20 April….
    php[24906]: /services_captiveportal.php: The command '/sbin/ipfw table all flush' returned exit code '71', the output was 'ipfw: Warn: Failed to get the max tables number via sysctl. Using the compiled in defaults. The reason was: No such file or directory ipfw: setsockopt(IP_FW_TABLE_FLUSH): Protocol not available'

    U have solution sir ermal….



  • Update your snapshot because ipfw is failing to load for you.



  • hello ermal.

    i have update with 21 snapshot but result it same, not change n still have problem

    php: /services_captiveportal.php: The command '/sbin/ipfw table all flush' returned exit code '71', the output was 'ipfw: Warn: Failed to get the max tables number via sysctl. Using the compiled in defaults. The reason was: No such file or directory ipfw: setsockopt(IP_FW_TABLE_FLUSH): Protocol not available'

    kernel: ipfw2 (+ipv6) initialized, divert loadable, nat loadable, rule-based forwarding enabled, default to accept, logging disabled

    please help me…



  • I've upgraded to pfSense-Full-Update-2.0-BETA1-20100421-2213 + gitsync'd and also seeing the same error reported by zchellpy.

    Thanks

    Slam



  • php: /services_captiveportal.php: The command '/sbin/ipfw table all flush' returned exit code '71', the output was 'ipfw: Warn: Failed to get the max tables number via sysctl. Using the compiled in defaults. The reason was: No such file or directory ipfw: setsockopt(IP_FW_TABLE_FLUSH): Protocol not available'

    21st of April snapshot, same issue here.



  • Only 1 April snapshot is good and no problem with captive portal.



  • ermal in snapshot 23 I have same issue errors

    php: : The command '/sbin/ipfw table all flush' returned exit code '71', the output was 'ipfw: Warn: Failed to get the max tables number via sysctl. Using the compiled in defaults. The reason was: No such file or directory ipfw: setsockopt(IP_FW_TABLE_FLUSH): Protocol not available'

    what is different in captive portal beetween snapshot 1 April with 23 April….???

    Thanks Before,

    Ermal



  • The date on FreeBSD RELENG_8 was bumped, which broke some things related to ipfw that Ermal fixed late today. 24th snapshots will have that.



  • In 24 snapshot is still have same log in system logs

    php: : The command '/sbin/ipfw table all flush' returned exit code '71', the output was 'ipfw: Warn: Failed to get the max tables number via sysctl. Using the compiled in defaults. The reason was: No such file or directory ipfw: setsockopt(IP_FW_TABLE_FLUSH): Protocol not available'

    but captive portal can run so well….

    sir Dev can I know what happaned....????



  • Nothing to worry is innocuous error, i see if it can be masked out totally.


Log in to reply