Slow internet speeds and external DHCP resetting



  • Recently we upgraded from a T1 to a Fiber connection. I installed the fiber connection on a OPT interface and routed traffic through it. Everything was working fine, except we coudn't use PPTP via our new connection. Our carrier asked that we leave the router on DHCP and they would send us our static IP.

    I made a new config file, and setup our new Fiber connection as the WAN port. Since then, DHCP resets every 5-10 seconds making things unsable. I was able to set the IP staticly, and it works, but we are only getting 1/3 the download speed, and 1/100 the upload speed that I can get when plugged directly into the connection.

    I'm sure the two issues are related. Any thoughts?



  • What version of pfSense?

    Have you tried disabling hardware checksum offload?

    What type of interface are you using (e.g. WAN is fxp, LAN is msk)?



  • Version 1.2.3-RELEASE

    I did not try disabling the checksum offload, but our connection and the service provider both worked fine on the nic that is still  being used.  The only difference is I changed the interface to WAN instead of OPT1.

    Also, the interface status screen doesnt show any errors

    Status  up
    MAC address –removed--
    IP address --removed-- 
    Subnet mask 255.255.248.0
    Gateway --removed--
    ISP DNS servers 10.10.10.10
    Media 100baseTX <full-duplex>In/out packets 172299355/131929085 (611.28 MB/3.74 GB)
    In/out errors 0/0
    Collisions 0

    I'm not sure about he "type" of interface. We are using an intel 4 port 10/100 card.</full-duplex>



  • @robinBones:

    I'm not sure about he "type" of interface. We are using an intel 4 port 10/100 card.

    They are probably fxps then. There is a known problem with the fxp driver in pfSense 1.2.3: it erroneously decides certain chips have hardware checksum capability.



  • Which packages have you installed?



  • I changed the hardware checksum offload setting, and that did not help, continued to drop connection, get link, re-obtain it's ip, then drop connection again.

    I had ntop installed, but just now I checked the installed packages and nothing was listed.

    Everything was working 100%, until I downloaded the config, and tried to manually swap OPT and WAN configurations.

    I feel like there has to be some kind of routing issue that is taking up all our bandwidth, and causing it to reset. When it is in static ip mode, the upload speed is really bad.



  • I've identified the issue,

    we have a cat5 connection from the service provider. I had that plugged into our main switch on it's own VLAN with the WAN setting on the router. The main reason for this is the physical length of the cable that was run from the service providers plug to our computer room.

    This morning I tried moving those two cables to a desktop switch that I had. I still have the DHCP resetting issue, but the speed is working at the full 100Mbit.

    I'm not sure why having a switch in linw would cause a speed issue like that, and a asymmetrical issue at that.

    I know our ISP is assigning the IP based on MAC, all I can think is it has something to do with that.

    Any one have any comments? is this normal?


Log in to reply