Issue with PFBox and DOM (possibly other issues)



  • Ok I looked to see if I could find any thing related to this however the closest I can find is "CF cards" however even thought a DOM (Disk On Module) is close enough they are slightly different in the sense that they attach directly to the disk interface (SATA, IDE, etc) and yesterday for unknown reasons when I attempted to install PFSense on the DOM as normal my interface for the WAN side would NOT get any IP at all…I followed the directions properly (and have already reinstalled at least 10 times for practice). so I go to install it onto the DOM and even PF sence doesn't seem to act as if it found the DOM or my WAN card, however I know the WAN (built in card with real tek chip set) worked before since I used it with an IDE spindle drive and its been going for at least a week well or longer, what could be going on? I really would like to try and use my DOM (thats why I got the thing) and put a full install on to it (in the configuration I use It almost never (if at all) wrote to the disk so disk write is not really an issue or a concern to me, plus It allows me to go nearly fan less (CPU and PSU will retain there fans).

    Anyone have suggestions for achiveing the install onto a DOM? and if possible why my onboard just suddenly stopped working on me? (only stopped after I shut it down and attempted a reinstall with 1.2.2 CD)



  • What version did you have on before - the one that worked?

    Have you tried 1.2.3 instead of 1.2.2?



  • I think the HDD (which I reinstalled what ever PFSence on was 1.2.3 but I think I have 1.2.2 because the installer was completely different then what I expected from what ever it originally had…it asked way too many questions then I remember, and now it says 1.2.2 so where the previous on the HDD was 1.2.3 (im certain of that since it had the web GUI already integrated and all and I think that was started in 1.2.3 only) and Im concerned that something is really messed up now...so I pulled the unit off my network and put a simple router (thankfully I keep most of my stuff for reuse) and put that in place of PFsense till that is fixed and working again...but yea I know previously it worked just find with what I got set up now so yea I don't know whats going on now...



  • I skimmed your posting because it was rather hard to read ;)  Try using complete sentences rather than partial thoughts all run together.

    If you'd previously been using 1.2.3, try 1.2.3 again.  That could easily explain why your WAN interface wasn't seen.



  • A couple of years ago I installed pfSense onto a Transcend "IDE" DOM. It would have been pfSense version 1.2.2 or older. The DOM looks just like a hard drive to the software, though nowadays its a pretty small hard drive.

    Perhaps you have a "new" motherboard and the "old" version of pfSense you have been trying to install doesn't recognise the WAN NIC and the disk controller.

    Perhaps you are using a SATA DOM. If so, the fact that pfSense 1.2.2 recognised your motherboard's IDE controller says nothing about whether it recognises any motherboard SATA controller.

    Perhaps you don't have power connected to the DOM.  (My DOM has a Molex "disk drive" connector which needs to be connected to the computer power supply and the DOM has to be plugged into the motherboard IDE connector though there are variants that plug onto an IDE cable. I have no experience with SATA DOMs.)

    Its been my experience that the BIOS can generally be configured to display at startup the disk drives present in a system. Does your DOM appear there?



  • BIOS finds it just fine it seems, but im redownloading PF 1.2.3 since the disk was 1.2.2 so I think its an older doesn't like newer situation….gonna see if thats the case and this is a 1GB IDE DOM...



  • ok update, got the new(er) version of PF downloaded (1.2.3) and when I attempted to boot the machine it started emitting an odd smell and the lovely magic smoke so at this time the machine is out of commission :( going to be looking into the innards to see what happened….


Log in to reply