USB Keyboard



  • Alright, I got a couple Dell Optiplex 210Ls to install pfSense on. These systems have no PS/2 ports, so I have to use a USB keyboard. When I try to boot from the LiveCD, it will eventually halt the USB system and reboot. I tried unplugging it after the kernel loads, and plugging it back in once it boots, but it just shuts off the USB port anyway. So I tried booting it with a serial console and was able to tell it which interface is which, but when the main menu comes up it is no longer on the serial console and I can't install it to the hard drive.

    I've also tried a couple different Dell USB keyboards and a PS/2 one with a USB adapter. Anyone have any suggestions?



  • Check in the BIOS should be a setting like enable USB keyboard emulation or something of the like. See if that works.



  • adjust the bios settings…..enable/disable legacy usb support, force to usb1.1, ect should get you working. I have used the livecd with usb keyboards without a problem before, to put it in perspective the usb support was on the intel 815chipset.



  • Thanks for the suggestions. Unfortunately it looks like Dell never put those options in the BIOS for the 210L. Stupid mistake getting a different box than usual  :-[ , I'm going to look around to see if there's either a PS/2 header on the motherboard or another way to force legacy mode.



  • You check the dell website for a bios update?



  • @rsw686:

    You check the dell website for a bios update?

    Yeah. I was surprised they haven't done anything since A02, but I'm guessing they don't see a need for including such options. I'll have to bug them and see if they'll add that in a future upgrade.

    I figured out a way around it. I setup the interfaces through a terminal (booting with the option set console=comconsole) and let it start all the way up. Then I went in through the web interface and enabled SSH. Once I SSH'd in, I was able to install it to the hard drive and then finish the installation from there. It's a bit of a pain (as I still can't use a local keyboard), but should be good enough for now.



  • I know this thread is old but I had the same problem with Dell 210L and the new Optiplex 320's. To get it to install on the 210L's i recompiled the kernel and took out ehci support. Then on the 320's I had to also remove ohci support. Once support for these 2 devices was removed from the kernel, I could boot pfSense and happily use the usb keyboard.



  • Hello everyone, this is my first post in this forum. I am a linux guy, hence I don't know much about FreeBSD, but I'm learning. :)
    I ran across the very same issue described here… I guess.

    I need to set up a firewall, I usually work with IpCop but I've read good things about this pfSense and I'd like to give it a try. The 1.2RC2 LiveCD loads fine on a vmware virtual machine, but on the machine it is supposed to be installed it doesn't: it displays

    ...
    ohci1: <ohci (generic)="" usb="" controller=""> mem 0xdfff8000-0xdfff8fff irq 17 at device 19.1 on pci0
    ohci1: [GIANT-LOCKED]
    usb1: OHCI version 1.0, legacy support</ohci>
    

    and it freezes, leaving me no choice but powering it off by hand :(

    The machine is a Dell Optiplex 320. I booted a Gentoo LiveCD, the output of lspci follows:

    00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 Host Bridge (rev 01)
    00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:12.0 IDE interface: ATI Technologies Inc SB600 Non-Raid-5 SATA
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
    00:14.0 SMBus: ATI Technologies Inc SB600 SMBus (rev 13)
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
    00:14.4 PCI bridge: ATI Technologies Inc SB600 PCI to PCI Bridge
    01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200]
    02:01.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
    02:02.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
    

    I tried compiling a kernel on a fresh FreeBSD 6.2, installed for the purpose, removing ehci and ohci support. Created the kernel image, mkisofs-ed the pfSense iso adding the new kernel and booted on the vmware. Result: it cannot mount root filesystem. I probably made some mistake making the iso. This is the command I used:

    mkisofs -rlvv -b boot/cdboot -no-emul-boot -boot-load-size 4 -c boot.catalog -o pfSense-DellKernel-1.2-RC2-LiveCD-Installer.iso /root/pfSense-Dell/
    

    I don't know what else to do… ipcop too seem to have some problems on that computer: it cannot find any hard drive! The SATA controller is probably too new for the 2.4.32 kernel of ipcop.

    Any help would be really appreciated! Wagonza, could you explain me the whole procedure? Anyway, thanks in advance for your time.



  • I had the similar problem related to boot-time freezing related to several reasons. I had to enable the legacy USB support to fix that issue (provided that your BIOS allows that setting).

    For further setup hint, look at your MoBo and pull out every PCI/e etc device to see if the system boots normally (Live-CD) . Introduce the cards (and USB driven devices such as CF cards) one by one to see which one is the problem.

    I have Jetway J7F4K1G2E and BIOSTAR GF8200 M2+ (with AMD Athlon X2 -45W & Intel dual NIC pci-e) for my firewall/proxy. Jetway MoBo did not work with the PCI network cards. All sorts of freezing came down to PCI card issue. Still do not know why (although I have a hunch that it could be related to filmsy PCI extender or PCI-memory-overlap). I used a USB ethernet adapter to make it work. Go figure! For the Biostar MoBo I had legacy USB support issue as well. Also EHCI handout disabling needed.

    Good luck!


Locked