Signature error when upgrading from 1.0.1 to 1.2.3



  • I recently had a crash after a power incident and had to re-install pfSense from the original live CD (ver 1.0.1). When I try to do a manual upgrade I get the error shown in the screenshot. I download it from two mirrors with the same result. I don't know if the error is bogus or not. Thanks for your help…

    In case you can't view the screenshot, the error text is:

    "The digital signature on this image is invalid. This means that the image you uploaded is not an official/supported image and and may lead to unexpected behavior or security compromises. Only install images from sources that you trust, and make sure that the image has not been tampered with. Do you want to install this image anyway (on your own risk)?"

    Jon



  • Rebel Alliance Developer Netgate

    That is normal for an older version such as that. You can bypass the error by installing the pubkey package before attempting the upgrade, so that it will use a different (updated) key to validate the signed image.



  • Thank You! I was able to install the upgrade with no problems…Jon


Log in to reply