NanoBSD on Alix 0.99h, 2GB CF: upgrades fail silently



  • Hi,

    I've been trying multiple versions of files but nothing works.  Here is what I have tried:

    NanoBSD April 12th to NanoBSD-update April 21: fail
    NanoBSD april 19th to NanoBSD-update april 21 : fail
    NanoBSD march 22 to NanoBSD-update april 21: fail
    NanoBSD april 12th to FULL VERSION update april 21: success, but that wasnt what I was going for so I had to revert (I need the two slices to save the box if needed).

    My upgrade log contains this at the end:

    File list:

    Warning: file_get_contents(/conf/file_upgrade_log.txt): failed to open stream: No such file or directory in /usr/local/www/diag_nanobsd.php on line 272

    Misc log:

    tar: Unrecognized archive format
    tar: Error exit delayed from previous errors.
    shutdown: [pid 58377]

    fdisk/bsdlabel log:

    I tried upgrading through the serial cable by URL by pointing to the .gz file and through the UI by uploading.  Everyone else seems to be happily upgrading, so what could be wrong?  In the case of the console cable, the file seems to be downloaded, and I answer yes to the "install even if signature is invalid question".  Things SEEM to work, but at the next reboot I am still on the old version.



  • Hello,

    I use the 17 april Snapshot on alix with 4g and all works correctly at this moment.

    Regards

    Jean-Noël

    PS:See my post : http://forum.pfsense.org/index.php/topic,24432.0.html

    !! i don't use update i start allways with an new image and restaure my values after !



  • im on the 21st snap and works fine, i manually upload upgrade file everytime



  • @xbipin:

    im on the 21st snap and works fine, i manually upload upgrade file everytime

    On my Alix the automated update fails also every time. I have to update manually also! This bug should be fixed asap!



  • auto update currently needs some more work but u can always download upgrade snaps and manually upload it using web gui



  • I understand auto-update doesnt work, but manual update doesnt work either for me!!! No upgrade method works, except doing a clean install which really isnt helpful.

    Could the fact that I have installed a package (siproxy) keep me from upgrading?

    So, where should I be looking for upgrade logs?



  • Ok, it worked now, but I do not know what I did different. Will run a few test to find out what it could have been, I suspect siproxy being installed created some issues…?


Log in to reply