[SOLVED]Bug, Traffic Graph Display Error.



  • In 2.0 Beta, Status -> Traffic Graph , The display of Host IP on LAN interface lose the last character, ex: 192.168.200.171 -> 192.168.200.17.


  • Rebel Alliance Developer Netgate

    What is the date on your snapshot?

    I'm not able to reproduce this error, though it may be that the IP addresses I have to work with are not that long.



  • Version: 2.0-BETA1 built on Mon Apr 12 22:17:25 EDT 2010
    This version may use only 14 characters, not full 15 characters.



  • While you're at it on the Traffic Graph, I also noticed that when I have ovpn interfaces, the Status -> Traffic graph is fine, but the Dashboard Traffic graph plugin doesn't pull any data for those exotic interfaces…

    If you're willing to spend a bit more time on this, a would be nice feature would be to combine traffic flow on 1 graph? Using my 7 OVPN WANs it'd be quote nice to see how traffic is being split by the load balancer versus having 7 different graphs being rendered.


  • Rebel Alliance Developer Netgate

    I've never looked at the code for the traffic graphing that deeply, that isn't something I'd be likely to take on. If you could describe the problem with OpenVPN interfaces in more detail, feel free to open a bug report for that on http://redmine.pfsense.org/

    As for the combined graph, you could open a feature request for that there also, but I'm not sure what the feasibility of that may be.



  • I try do some thing in 'bandwidth_by_ip.php' file, and I found that:

    when exec the following command :

    rate -i le1 -nlq 1 -Aa 10 -c 192.0.0.0/8 | awk '{ printf "%s:%s:%s:%s:%s\n", $1, $2, $5, $8, $11 }'

    i get the result:

    Momentary:Rx:Average:Tx:
    Bps:pps:pps:pps:pps
    192.168.200.147:3.71k:4.95:9.90:

    They seems OK, but when i dump the $listedIPs[$x] when $x = 2,
    it show that:

    192.168.200.14:3.71k:4.95:9.90:

    missing one character '7'.



  • There are maybe some thing worng at previous post, after test again,

    rate -i le0 -nlq 1 -Aa 10 -c 192.0.0.0/8

    Momentary Rx    Momentary Tx      Average Rx      Average Tx
                      Bps    pps |  Bps    pps |  Bps    pps |  Bps    pps
    192.168.200.16  38.20k 129.19 | 22.90k 129.19 | 38.20k 129.19 | 22.90k 129.19

    the ip
    192.168.200.16 –> should be 192.168.200.161

    ,so maybe something wrong in rate command ..


  • Rebel Alliance Developer Netgate

    I added a patch to rate in the repo so the next time it gets rebuilt it may be fixed. I'm not sure if it will rebuild that port automatically or if I'll have to ask to have it rebuilt



  • After updated, the problem has solved, thank you.
    Version: 2.0-BETA1 built on Sun May 2 18:59:27 EDT 2010 FreeBSD 8.0-STABLE


Log in to reply