[RESOLVED] PPPoE reconenction issue



  • the pppoe reconnection issues still stands coz in the last few days i have had internet dropuouts and i noticed pppoe wont reconnect, it tries to but for some reason it doesnt connect inspite of the link being on, systemlog shows the below

    Apr 23 09:53:42 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:53:42 	wan: [wanL1] Link: DOWN event
    Apr 23 09:53:42 	wan: [wanL1] LCP: Down event
    Apr 23 09:53:42 	wan: [wanL1] Link: reconnection attempt 3406 in 3 seconds
    Apr 23 09:53:45 	wan: [wanL1] Link: reconnection attempt 3406
    Apr 23 09:53:45 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:53:54 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:53:54 	wan: [wanL1] Link: DOWN event
    Apr 23 09:53:54 	wan: [wanL1] LCP: Down event
    Apr 23 09:53:54 	wan: [wanL1] Link: reconnection attempt 3407 in 2 seconds
    Apr 23 09:53:56 	wan: [wanL1] Link: reconnection attempt 3407
    Apr 23 09:53:56 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:54:05 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:54:05 	wan: [wanL1] Link: DOWN event
    Apr 23 09:54:05 	wan: [wanL1] LCP: Down event
    Apr 23 09:54:05 	wan: [wanL1] Link: reconnection attempt 3408 in 4 seconds
    Apr 23 09:54:09 	wan: [wanL1] Link: reconnection attempt 3408
    Apr 23 09:54:09 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:54:16 	miniupnpd[47707]: ioctl(s, SIOCGIFADDR, ...): Can't assign requested address
    Apr 23 09:54:18 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:54:18 	wan: [wanL1] Link: DOWN event
    Apr 23 09:54:18 	wan: [wanL1] LCP: Down event
    Apr 23 09:54:18 	wan: [wanL1] Link: reconnection attempt 3409 in 1 seconds
    Apr 23 09:54:19 	wan: [wanL1] Link: reconnection attempt 3409
    Apr 23 09:54:19 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:54:28 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:54:28 	wan: [wanL1] Link: DOWN event
    Apr 23 09:54:28 	wan: [wanL1] LCP: Down event
    Apr 23 09:54:28 	wan: [wanL1] Link: reconnection attempt 3410 in 1 seconds
    Apr 23 09:54:29 	wan: [wanL1] Link: reconnection attempt 3410
    Apr 23 09:54:29 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:54:38 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:54:38 	wan: [wanL1] Link: DOWN event
    Apr 23 09:54:38 	wan: [wanL1] LCP: Down event
    Apr 23 09:54:38 	wan: [wanL1] Link: reconnection attempt 3411 in 3 seconds
    Apr 23 09:54:41 	wan: [wanL1] Link: reconnection attempt 3411
    Apr 23 09:54:41 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:54:50 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:54:50 	wan: [wanL1] Link: DOWN event
    Apr 23 09:54:50 	wan: [wanL1] LCP: Down event
    Apr 23 09:54:50 	wan: [wanL1] Link: reconnection attempt 3412 in 4 seconds
    Apr 23 09:54:54 	wan: [wanL1] Link: reconnection attempt 3412
    Apr 23 09:54:54 	wan: [wanL1] PPPoE: Connecting to ''
    Apr 23 09:55:00 	php: /index.php: Successful login for user 'admin' from: 192.168.0.11
    Apr 23 09:55:03 	wan: [wanL1] PPPoE connection timeout after 9 seconds
    Apr 23 09:55:03 	wan: [wanL1] Link: DOWN event
    Apr 23 09:55:03 	wan: [wanL1] LCP: Down event
    Apr 23 09:55:03 	wan: [wanL1] Link: reconnection attempt 3413 in 2 seconds
    Apr 23 09:55:05 	wan: [wanL1] Link: reconnection attempt 3413
    Apr 23 09:55:05 	wan: [wanL1] PPPoE: Connecting to ''
    

    im on the 21st nanobsd snap



  • my mpd config is as follows

    startup:
            # configure the web server
    	set console close
            set web close
    
    default:
    pppoeclient:
    	create bundle static wan
    	set iface name pppoe0
    	set iface route default
    	set iface disable on-demand
    	set iface idle 0
    	set iface enable tcpmssfix
    	set iface up-script /usr/local/sbin/ppp-linkup
    	set iface down-script /usr/local/sbin/ppp-linkdown
    	set ipcp yes vjcomp
    	set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    	create link static wanL1 pppoe
    	set link disable incoming
    	set link action bundle wan
    	set auth authname "username"
    	set auth password "password"
    	set link keep-alive 10 60
    	set link max-redial 0
    	set link no acfcomp protocomp
    	set link disable pap chap
    	set link accept chap
    	set pppoe iface vr1
    	set pppoe service ""
    	set link mtu 1492
    	open
    
    


  • actually this
    set ipcp yes vjcomp

    if set to
    set ipcp no vjcomp

    then it works just fine and reconnection is also fine, could any1 tell me the importance of it?



  • also noticed in interfaces.inc

    shouldnt line 2199 as well as 2349 both be
    set ipcp no vjcomp



  • requesting ermal to apply this patch so i can get rid of this pppoe reconenct issue
    http://redmine.pfsense.org/issues/show/540



  • If you want an immediate fix, change line 2199 in the /etc/inc/interfaces.inc file on your pfsense box.

    GB



  • actually i tried all that but when pfsense is running and i tried editing include files or even try uploading using SSH and then try a reboot, the system gets messed up and wont boot to normal and i have no clue how to kill the web gui first then upload the changes and then restart it



  • Hmmm,
    That's strange. As long as you aren't clicking buttons on the WebGui while editing it shouldn't matter if you edit the interfaces.inc file while the system is running.

    Did you do this? Actually, this first line is only valid for NanoBSD installs as far as I know. What install are you running?
    #/etc/rc.conf_mount_rw
    #vi /etc/inc/interfaces.inc
    –--- make changes ----
    set ipcp disable vjcomp

    --- save (":wq") in vi----
    Go restart pppoe connection in Status-> Interfaces



  • im on nanobsd on alix and editing files using console it a bit limited so i usually downlaod the file using ssh, modify it and upload it and set the permissions again properly and reboot and then its disaster



  • Latest snapshots should have the change.



  • thanks for the effort, works fine now



  • …pardon my ignorance, but how is this issue addressed?

    I think I may be affected by it too



  • its been solved already on 2.0 by setting compression to off so first kindly run the latest 2.0 snap then go to the wan page and simply click apply so compression can also be set to off in ur config and then try it, the patch applied was for nanobsd, no idea if its the same for full installs


Locked