After rebooting, could not mount fom UFS…



  • Hello,

    I am new to FreeBSD, and I ran into a boot problem after rebooting, fixed it, and now I'm not sure how I fixed it or why it happened.

    I wanted to test my atom server (1U Supermicro) with FreeNAS, so I thought I would be smart and disconnect my SATA drive and test on a thumbdrive. All was well until I booted pfSense, and received and error: trying to mount root from UFS:dev/ad4s1a , and it repeated a few times. So I followed the prompt and hit ? to list the "partitions", which where labeled something like ad6s1c, adcs1b, ad6s1a, so I picked the last one because it was similar to ad4s1a (from what I recall, a slice is like a partition and I assumed thats what the s1a is??).

    My board has one IDE port and 4 SATA ports, would the ad4 , ad6 be different ports??? I thought I plugged it into the correct one  ???

    If anyone would be kind enough to shed some light, or point me in the right direction, I can't seem to get the right keywords, and haven't finished the pfSense book yet.



  • This sort of thing tends to happen with FreeBSD when you move the boot drive such that its name changes (e.g. you connect the drive to a different socket on the same motherboard OR move it to another computer such that the drive has a different name).  In either case, the drive name might change from ad4 to ad6.

    Once you have selected the correct drive FreeBSD generally corrects this problem itself so that it doesn't recur until the next time you move the boot drive.



  • Ooooh…...thanks  ;D

    Knowing me I just plugged it into any ole SATA port.

    Thanks again!


Log in to reply