Weird fdisk error, but installation worked after all



  • Hello, I'm a student at a junior high school in Mexico. We have about 150 computers that are of the students, and around other 15 of the teachers. We used Ipcop for the routing and proxy, but because of something that we don't really know, some stuff got corrupted in the installation. (I was planning to change it sooner or later anyway, and I had researched about m0n0wall a year ago and had it in a test box, loved it, but then I got to know pfsense and I liked the idea, still not a final version but when I needed it, it was ready. :) ) The performance is much better than IpCop, I was sure that it would be, but not that noticeable, especially in browsing it improved.

    The installation was easy, I first started by booting the LiveCD, then I assigned the network cards, then I just went to the installer, and I was going to prepare the hard disk, it told me that the way cylinders, blocks and sectors were configured would not let me boot FreeBSD, and it recommended me some numbers, so I accepted and continued the installation, then it asked me if I wanted to format, I chose to, then it asked if I wanted to partition the hard drive, and I didn't need it, I skipped that part, then that it needed to install something named bootstrap if I remember well, for boot FreeBSD, went ahead, fine, then it was going to do the changes, I selected yes, and it failed, it told me that it fdisk failed with error 1, that the sector should be between 1-63, okay, I cancelled and went back to check, and it was 63) like it should be, so I tried again, the same problem, a few times the same, then I decided to try to skip, even if there was an error, surprisedly, it installed without problems. But I just wanted to report that it happened, I don't know if it is a bug or my fault.

    The system is:
    Pfsense 1.0 Final
    Via Chipset VT8235 (I don't know the motherboard number, but I will check out tomorrow, also I'm not that sure if this is the real number, I checked on the Internet and it seems so, I confirm tomorrow)
    Samsung 40GB Hard Drive (Not sure of the model, I could check if it is needed)
    Kingston 256MB DDR Ram
    LG CD-ROM
    Via Network Card and a Realtek Network Card (I know, that's crappy, but it does the job)

    Thanks, pfsense really rocks!

    Edit: Sorry if this is the wrong section, maybe it would fit better in: Installation and Upgrades but this looks more like hardware problems.

    Edit2: The error looks similar to the one in this thread: http://forum.pfsense.org/index.php/topic,693.0.html but here I could get it to format.



  • Check your Bios for the settings mentioned in this mail: http://www.mail-archive.com/support@pfsense.com/msg03811.html

    Sometimes it seems to have problems detecting the correct diskgeometry.



  • @hoba:

    Check your Bios for the settings mentioned in this mail: http://www.mail-archive.com/support@pfsense.com/msg03811.html

    Sometimes it seems to have problems detecting the correct diskgeometry.

    Thanks man, I had packetmode off, but the Bios settings were in Auto, so that's why it happened.

    Thanks again.


Log in to reply