Config not writing to floppy



  • Good evening.
    I'm trying a new pfSense version 1.2.2 install. I have it working except for one small problem.
    I cannot transfer my config file to the floppy. I always get 'Error mounting fd0'.

    When I use option 98 to transfer the config it does present 'fd0' as an available option.
    I have formatted the disk and checked it for errors.

    I believe there was a problem with version 1.2.2 and the floppy disk but I cannot upgrade to 1.2.3. That version does not run on my old hardware.

    Can I possibly download the config through the web interface and write it to the floppy on another system?
    If so is there a directory structure I need to create?

    Thanks



  • @jays:

    Can I possibly download the config through the web interface and write it to the floppy on another system?
    If so is there a directory structure I need to create?

    The config, when downloaded via the GUI, is a single XML file, nothing more.

    Cheers.



  • I understand the config file is an xml file.

    What I don't know is what is stored on the floppy when you "move the configuration file to a removable media". Since the version I have doesn't do that function I thought I could do it manually.

    Will copying the xml file to the floppy accomplish the task of persisting the configuration?

    I'll try it tonight and/or try an earlier version in the hope of finding one that works with my hardware.



  • @jays:

    What I don't know is what is stored on the floppy when you "move the configuration file to a removable media". Since the version I have doesn't do that function I thought I could do it manually.

    Will copying the xml file to the floppy accomplish the task of persisting the configuration?

    I don't know, because the 1.2.3 version I'm running doesn't seen to have a "floppy" option, either in the GUI, or by logging in via SSH.  Where do you see that option.

    Cheers.



  • It's in version 1.2.2. The current version does not boot on my hardware.

    option '98' on the console.
    "Move configuration file to removable media".
    Choose "fd0" from the presented list of media to mount.
    "Error mounting fd0"



  • version 1.2.1 does the same. versions later than 1.2.2 all fail to mount the cd on boot. Same symptoms when booting monowall.
    device names tried:  fd0, fdc0, disk0, /dev/fd0  all fail.
    must be a bsd thing.


Log in to reply