I'm completely baffled - web pages never fully load



  • I'm finding that web pages don't complete.  There is usually an image or something that isn't loaded.

    Here is my setup.

    lan –-- pfsense 1.2.3 ---- speedtouch 585v7 ---- dsl

    The speedtouch 585v7 is running a pptp server and acting like a modem.

    The wan side of my pfsense box is using pptp to connect to the speedtouch.

    The first day I tried this... all seemed to work fine.

    Yesterday, for some unknown reason, I had to manually set the MTU on the wan side of the pfsense box to 1400 to get simple pages like google to complete.

    Now, I'm finding that some web pages never complete.  Like forums.  There are always images etc. that never finish loading.

    As my pfsense box is an old 533mhz via C7 box... I've turned off checksum offloading to see if that helps.

    Has anybody come across anything like this before?  I'm really stumped and don't know where to turn now.

    Thanks.

    -- gyre --


  • Rebel Alliance Developer Netgate

    Usually what you describe does turn out to be an MTU issue of some sort.

    Why not fully bridge that DSL modem and let pfSense handle everything else?



  • Thanks for replying.

    Yup, I think I'm going to have to do that, to be honest.

    If fully bridged, would I use pppoe or dhcp to connect?

    You don't happen to know of a config that works on it, do you?  The only ones I can see via google are on a 'be' forum that you can't register on until you're actually on a 'be' network to get the downloads.

    Thanks.

    – gyre --


  • Rebel Alliance Developer Netgate

    I don't know if it's pppoe or dhcp, that is up to your ISP. You may be able to login to that device and see how it is setup. I'm not familiar with speedtouch devices, but typically doing a reset on DSL "routers" (usually just smart modems) will effectively turn them into a bridge.

    If your ISP supplied the device they may be able to tell you what to do.



  • Thanks.

    I do have a DG834G v4 I could also try out, I guess :)

    – gyre --



  • do as jimp said or another way is to put the modem in bridged mode with passthrough (modem handles the login process and then give the pf box a wan IP, almost like a cable modem)



  • I switched to using a netgear DG834Gv4 in dumb modem mode.  Connected to it via PPPoE from the Wan interface.

    That didn't have the 'page wont load cos the MTU is wrong' problem as such… I could leave the MTU slot empty on the Wan interface menu and I was able to see most web pages.

    However, it still has the problem that when I view a page that has lots of different images, like http://news.bbc.co.uk or even this forum, I often find that some images are refusing to load... and that firefox is waiting forever for them to complete.

    If I re-load the page, often they will then load OK.

    It's almost as if packets are getting silently lost by the router.

    I then replaced the router with an old d-link dgl4300 and don't have any of these problems, so, with my limited amount of testing, I think that perhaps my old via-based box may be dropping stuff randomly under stress.

    -- gyre --



  • If your isp uses PPPoE then you must take in consideration MTU, try playing about with different amounts, but most PPPoE MTU is 1492.

    I dont think your 533mhz cpu is the issue, Ive ran 500mhz machine when I first started using pfsense with 10 users without any problems, especially in your case as you're testing (I presume just one user).

    As for Be/o2 internet, they use ETHoA, so their modem settings most probably wont work with your ISP, not to mention they use VPI/VCI - 0/101 and they dont use authentication regardless of the modem bridged or not.

    Which ISP do you use?

    Slam

    P.S try upgrading the firmware if its available for the DG834Gv4



  • Thanks for replying.

    My ISP is plusnet.  I'm not LLU, I'm on a normal BT exchange with 21C, but not ADSL+ as I'm too far from the exchange to take advantage of it.

    On plusnet's forums I can see that other folks are using PPPoE just fine with them.

    They use the standard BT VPI/VCI 0/38.

    Yup, using PPPoE means my MTU has to be a little less than 1500.  I'm using 1492.

    I'm on the latest non-US firmware for the DG834Gv4.  It's currently in dumb-modem/bridge mode via the standard url hack.

    So far, my old d-link dgl4300 gaming router is working fine with the DG834Gv4 in PPPoE mode.  No uncompleted page loads.

    However, I'd far rather use pfsense.  That's why I'm here :)

    I'm not pegging the CPU on the 533mhz Via chip that I can see.  Downloading 20 SSL connections from my usenet server works a dream.  Going full rate.

    It just seems to be spikey web pages loads… like loading a new web page with lots of images that causes things to get lost/go wrong.  Things like page loads aborting... or image loads hanging.  Just regularly enough to be annoying.

    Note I did have to disable DMA on IDE for the CF chip, or pfsense wouldn't boot.

    I'm wondering if the network chips need a workaround.  They seem to be that model that everybody's complaining about.  realtek?  I tried disabling the checksum offload, but that didn't make any difference.  I tried device polling, and neither did that.

    -- gyre --


Log in to reply