Snort 2.8.5.3 pkg v. 1.24 upgrade issues



  • I am using snort 2.8.5.3 pkg v. 1.24 on pfsense 1.2.3-RELEASE

    Problem upgrading from 1.2.2 to 1.2.4 (also upgrading to 1.2.3 did the same thing):
    1. I backup my snort 1.2.2 package info
    2. I uninstall snort 1.2.2
    3. I install snort 1.2.4
    4. I "restore" package info
    5. Snort reports I am using version 1.2.2

    This causes snort to have all sorts of errors when updating rules and starting services. Any ideas? I'd hate to have to start my rules from scratch. Also, I have a large block list I don't want to lose.

    -Sean



  • When I updated from 1.22 I noticed it kept my list after upgrading to 1.24. It is very possible your list is too big or there is an entry in it causing to fail. Using shell rename your block list prior to upgrading and restore it after. See if that will work.



  • @g4m3c4ck:

    When I updated from 1.22 I noticed it kept my list after upgrading to 1.24. It is very possible your list is too big or there is an entry in it causing to fail. Using shell rename your block list prior to upgrading and restore it after. See if that will work.

    By "upgrade" what do you mean? Did you delete and install? Did you reinstall?

    -Sean



  • Try to reinstall the package, my first code upload of snort package 1.24 was corrupted.

    James


Log in to reply