2 wan setup - only one wan passing traffic



  • Hello All,

    Setup first pfSense wall in school eviornment. – pfSense 1.2.3
    Multi-Wan setup.
    1)  wireless incoming connection which is simply an bridge outside the building, equivilant of T1. wan/nic >  cat5> bridge
    2) dsl connection via the wan/opt2,>  dsl modem/router.
    I am very familiar with Linux but never delt with FreeBSD before,FYI.
    OK, set the box in place today and wan links came up right,as I could ping each public gateway once set in place.
    After having the box in place for the day. done some checking and come to find out,only traffic was being used by the wireless outgoing wan conn. I seen this via the interface that showed the amount of traffic passed. The second wan only showed about 800kb passed in 8 hours which I am guessing is merely ping requests out?
    I went by the pfsense wiki on how to set up multi-wan for pfsense 1.2.x.
    It appears the round-robbin is not round-robbining...:-)
    WAN= >wireless/bridge
    OPT2=> ADSL router
    The Load balancer status always showed green,with very little latency on both conns.
    Done some traceroute from a  remote machine back into the school lan,and looked like the traceroute did end up hitting the wan1 & wan2 nic as expected.
    OK. So how do i troubleshoot this scenario?
    I pretty much expected some heavy snafoos as this being my first pfSense setup.
    Stupid question: in every example I look at for multi wan setups,an internal/class c ip address is used for the wan connection?
    Of course with my setup both links are to public ip/class a ip's. Is this a problem?Is it literally impossible to have two gateways on one machine/router to make this happen beings it is non-routeable ip's?
    I'm stumped ,,,:-)
    Any ideas?

    Thank You,
    Barry



  • sorry if this is stating the obvious…
    have you selected the loadbalancer as the gateway in your outbound rules on firewall/rules/LAN tab?

    the private / public address range on your WANs doesn't matter. it should work either way.

    gordon



  • gordon,,,

    thank you much!! for the quick feedback.
    OK,,,I did see this listed in one of the multi-wan howtos as you explicitly stated..
    I do not see in the firewall lan rules,,outbound rules a selection for loadbalancer?
    this is what puzzled me,?
    I think i just have the default,,?…Lan rules outbound..
    Like I said ,,my first pfSense setup,,and Im sure I am missing things,,even though I have delt with linux configs in general,,for a long time..
    Should I be seeing a selection,in the drop down in outbound /lan firewall rules named loadbalancer: exactly?..
    I do see like WAN/LAN,,???others but noghting that states loadbalancer,or "pool name" ..?
    Ok showing my ignorance...:-)

    Thanks,
    Barry



  • OK Barry, something not quite right with your loadbalancer setup then.

    So, you go to Services | Loadbalancer and create a new 'Pool'
    Select type 'Gateway' and behaviour 'Load Balancing'.
    Add both of your WAN interfaces to the pool, selecting a monitor IP for each before you click the 'Add to Pool' button.
    Save the load balancer setup.

    Go to Firewall | Rules | LAN
    Either create a new rule or modify the default rule and you should be able to select the name of your Loadbalancer Pool in the Gateway dropdown list.

    Is that how you set up the LB?



  • Gordon,

    Thanks again,
    As you stated.I did not have my LB Pool set up correctly,
    I went through the 1.2.3 LB setup again.
    Now I had the LB,,name,,, as an option for gateway.
    It appears now both nics are sending/receiving about the same amount of data!,,,,yyyeaaahhh!
    Going to pfsense ip.php the ip address changes as it should!
    Now,,I can not get a ping response from any of my created VIP's/Typep-ARP to forward ports for internal mail server to public.
    That'll be a post to VIP section forum
    Getting closer!

    Regards,
    Barry


Log in to reply