Reinstalling Snort nulled everything



  • I re-installed Snort and it nulled everything, my Snort interfaces, everything. Is that the correct re-install behavior?

    TIA

    pfS 1.2.3-RELEASE reinstalled from Snort 1.22 to 1.24 I think



  • I had the same thing happen to me on that upgrade but I noticed that the new 1.24 version has a check box under "Global Settings" for "Keep snort settings after deinstall", and "Settings will not be removed during deinstall." which is a good idea I think.

    I don't think the 1.22 version had this.  If it did I completely missed it.



  • @TreeTopFlyer:

    I had the same thing happen to me on that upgrade but I noticed that the new 1.24 version has a check box under "Global Settings" for "Keep snort settings after deinstall", and "Settings will not be removed during deinstall." which is a good idea I think.

    I don't think the 1.22 version had this.  If it did I completely missed it.

    Nope. v1.24 is the first build to incorporate this awesome feature. Thanks James(Dean) for your continued efforts on our behalf. Bravo!



  • Agree with Roodawakening. The 1.24 now working excellent after JamesDean has point out my silly setting. The "Blocked" list and "Alert" list is now lighting fast to display all blocked IP.

    "Keep snort settings after deinstall" is a new function which started on 1.23.  In the 1.24 work perferctly, I have tried to deinstall the packages and all the snort setting remain fine.

    Once again, Thanks JamesDean for the supreme effort on the Snort packages.  ;)



  • I would have guessed that a reinstall should remember all settings as most (all?) of the other packages I have used do that. I can't remember any notes on this matter from 1.22. I know Freeswitch have settings outside xml but that's clearly noted in Freeswitch together with backup feature.

    But as of 1.24 this is no more an issue then(?). I haven't had the time to set things up again yet, but will do in 7-8 days.



  • It was a touch and go week with snort and pfs, but thanks to JamesDean things are running excellent.

    I am using v1.24 with Premium Rules and have no more issues to report. Screens appear much faster and all the rules are updating as expected.


Log in to reply