Upstream Squid Proxy via IPSEC



  • Hello everyone,

    I currently have 2 machines running pfSense 1.0 RELEASE with IPSEC enabled between the two networks.
    Network A: 192.168.0.0/24
    Network B: 192.168.1.0/24

    I have the squid package installed on the router of Network B. Now I would like to do transparent http proxying and pass the data to the http filtering daemon on Network A (192.168.0.12). I added a static route to Network A on the router of Network B (route add 192.168.0.0/24 192.168.1.1).

    on the router of Network B I also setup a transparent squid proxy server with the upstream server set as 192.168.0.12 (Network A) port 8080. With logging enabled I see the http requests passing through the router of Network B however I do not see them being forwarded to the daemon on 192.168.0.12 port 8080.

    When I disabled transparent proxy filtering and set my browers proxy ip to 192.168.0.12 port 8080 I am able to access the proxy just fine.
    Any thoughts on where squid is going wrong?



  • I was able to work around this by creating a port forward nat rule on the lan interface with the ip as ANY with the external port as http and internal ip/port as 192.168.0.12:8080
    then i disabled the local squid proxy.


Log in to reply