2 DHCP WAN w/L_balance_failover



  • Hi all,
    Hoping some of the higher ups can help me with this.

    1.2.3-RELEASE  installed on a “Hacom” Mars class pfSense router.
    Trying to achieve load balance and failover. Setting seem correct but not sure exactly what static routes are need from this paragraph in Multi-WAN Version 1.2.x or if I'm missing other settings.

    from guide:
    Setting up DNS for Load Balancing
    Make sure that you have a DNS server from each ISP in the General Settings. This will ensure that you have DNS service in case one ISP goes down. You will also need to setup Static Routes for each DNS server. In this example if the DNS is on the WAN link then the static route for that DNS server will have 192.168.0.254 as the gateway. If the DNS server is on the other ISP (ie OPT1) then the static route will have have 192.168.1.254 as the gateway.













  • Here's the thing, unless you are using a routing protocol with your ISP provider, your PFsense won't know any routes to the outside world except for the default route that is created by the Active and Working WAN interface.  (WAN1 in your case).

    You'll need to tell the firewall where exactly to reach each DNS server pointing the route to their respective x.x.x.1 gateway on the appropriate interface.

    Just configure the first static route for the ISP1 DNS server address to exit via WAN1's IP gateway.
    Then configure the second static route for ISP2's DNS server address to exit via WAN2's IP gateway.

    –Jam



  • Thanks for the reply.
    Not sure I understand. Tried this but still no round robin?

    added: from firewall log..lota WAN2 blocks.






  • A problem with the round robin probably won't be caused by a DNS issue, and I'm not sure how to configure the load balancing part because I haven't set it up yet in my own lab yet.

    The DNS configuration with the static routes, is simply a way to make sure you can still get DNS resolution even after your primary WAN interface goes down.

    Can you show me what routes you have configured in the firewall right now?  I can double check and let you know what other routes you need to add.

    –J



  • Thanks for advice/comment.

    There was a default firewall rule "Default Lan> any" . I did not add it?

    I disabled it and 2nd wan works.




  • Did some  forum searching, seems like I should have that rule?
    Firewall: Rules: Lan = Default Lan >any
    Maybe the Gateway should be "Loadbalance" instead of "Default"?
    I see a lot of errors in firewall log, not sure what they are.
    But Loadbalance seems to be working.



Log in to reply