Problème squidguard après redemarrage pfsense



  • Bonjour,
    j'ai installé pfsense sur un pc avec 2 cartes réseaux afin de faire un portail captif publicitaire.
    après connection sur le portail captif je dois restreindre l'accès a 4 sites internet.
    J'ai donc installé et configuré squid et squidguard.
    tout fonctionne bien.
    Quand je redémarre le pfsense, j'arrive bien sur le portail captif, je me connecte, et apres j'ai accès a tous les sites et non pas les 4 mis dans la white list.
    Un clic sur apply dans le proxy filter suffit a remettre le tout en ordre.

    Quelqu'un aurait-il une idée pourquoi le service ne se lance pas correctement au démarrage ?

    Merci d'avance



  • Bonsoir,
    je vois que personne n'a déjà eu le problème.
    Même pas une piste ou chercher le soucis ?
    Merci d'avance



  • je vois que personne n'a déjà eu le problème.

    Il ne me viendrait pas à l'idée de transformer Pfsense qui est un firewall rappelons le, en portail captif publicitaire et d'y installer un proxy.
    C'est peut être à cause de cette habitude qui consiste à utiliser le bon outil pour un travail donné que je n'ai jamais eu ce problème.



  • Bonsoir,
    je ne me suis pas posé la question d'externaliser le proxy car le package est propose par pfsense.
    Je ne comprend pas pourquoi il y a tant de package dispo si on ne peut pas s'en servir.

    Sinon j'avais fait un essais sans portail captif et juste avec squid et squidguard installe dans pfsense et cela faisait le même problème.
    Si je dois installer le proxy a part, que me conseillez vous comme distribution?
    Merci d'avance



  • Effectivement, on peut se poser cette question.
    Dans l'absolu, ces paquets fonctionnent.
    Mais la réflexion de ccnet est le résultat de l'expérience acquise par les années.
    (Je partage très souvent les réflexions de ccnet et … ce n'est pas si surprenant !)
    (Le type même de paquets de ce genre est Snort : très dangereux ... pour l'esprit !)

    Le bon outil ! A la bonne place ! (Les anglophones disent : the right man at the right place !)

    Pour un proxy, on peut, si on aime bien ajuster SA config, partir avec une Debian et ajouter ce qu'il faut :
    Squid + SquidGuard + blacklist + cron maj blacklist + havp (version testing) + clamav (version testing) + authentification + LightSquid (+Apache) + ...
    (Comptez quelques jours, ou plus, de mise au point ...)

    On peut partir avec des distrib spécialisées genre Artica ou ClearOs (Clarkconnect).
    Mais ce sont des outils "plus larges", donc pas forcément les mieux adaptés.



  • J'ai aussi lu que les contributeurs de pfSense, eux même ne les préconises pas forcement …



  • J'ai le même problème. Au lieu de le contourner, j'aimerais le résoudre, d'autant qu'il s'agit d'un réseau de 4 ou 5 postes à filtrer pour des jeunes mineurs.



  • Avec 4 ou 5 micros, il ne me parait pas TRES difficile de configurer Squid et le réglage sur chacun de ces 4 PC avec BIEN SUR l'interdiction d'aller sur Internet pour TOUT matériel.

    La règle LAN vers WAN sur port 80/tcp INTERDIT n'empêche nullement à un PC configuré de passer via le proxy SQUID dument configuré.

    Cela est acceptable pour 4-5 micros. Mais, à partir de 10, il est à recommander d'utiliser un proxy dédié, point barre.



  • J'ai bien compris l'avertissement quant au nombre de postes. Il est suffisamment répété ici.

    Mon problème c'est que j'y arrive très bien mais qu'au redémarrage ça ne fonctionne plus.
    J'ai ouvert un topic ça me parait plus propre:
    http://forum.pfsense.org/index.php/topic,28521.0.html


Log in to reply