Vlan is 100baseTX on gbit nic



  • Hello.

    I got a nice new switch that supports vlan and i have it working. The only thing i have noticed is that the vlan's i have it shows that is is a 100baseTX nic but i have a gbit nic.

    Is there a problem or should it say that it is a slower speed that what the nics support?

    ![pfsense interfaces.png](/public/imported_attachments/1/pfsense interfaces.png)
    ![pfsense interfaces.png_thumb](/public/imported_attachments/1/pfsense interfaces.png_thumb)



  • VLAN is a virtual interface. I expect that regardless of what the VLAN interface speed is reported to be that your maximum bandwidth over a single active VLAN won't be very much different from the maximum bandwidth available from the underlying physical interface.

    Its not clear what interface speed a VLAN interface should report. Imagine 20 VLANs on a 1Gbit physical link. Should the VLANs all report 1Gb? 100Mb? 50Mb?



  • The problem that i have is that i can't get gigabit speeds on my network. The gigabit switch that i have sees the link to the router as 100baseTX and not 1000baseTX.

    I ran iperf on the network and i'm far from impressed.

    [148] local 10.0.0.47 port 50185 connected with 10.0.0.254 port 5001
    [ ID] Interval      Transfer    Bandwidth
    [148]  0.0- 1.0 sec  11.1 MBytes  93.1 Mbits/sec
    [148]  1.0- 2.0 sec  10.8 MBytes  91.0 Mbits/sec
    [148]  2.0- 3.0 sec  11.1 MBytes  93.2 Mbits/sec
    [148]  3.0- 4.0 sec  11.1 MBytes  92.9 Mbits/sec
    [148]  4.0- 5.0 sec  11.0 MBytes  92.6 Mbits/sec
    [148]  5.0- 6.0 sec  10.9 MBytes  91.3 Mbits/sec



  • Please post the output of shell commands ifconfig -a and dmesg so we can get a better idea of what interfaces you have.

    Have you tried swapping the WAN and LAN interfaces? Why do you think your LAN interface is gigabit capable? (If I recall correctly there are some interfaces supported by the em driver which are NOT capable of gigabit speeds though most interfaces supported by the em driver are gigabit capable.)

    Depending on the I/O configuration of your motherboard, it may not be possible for your gigabit interfaces to sustain throughput of 1Gb/s. For example, standard PCI bus has a theoretical absolute maximum I/O bandwidth of about 1Gbps and that has to be shared across reception and transmission and other devices on the same bus.



  • The hardware i'm running on is a HP Proliant DL360 and i was getting gigabit speeds when i didn't use vlan. I havent tried swapping WAN and LAN but i might later.

    ifconfig -a

    $ ifconfig -a
    em0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:19:bb:e9:ea:c0
    	media: Ethernet autoselect
    	status: no carrier
    em1: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:19:bb:e9:ea:c1
    	media: Ethernet autoselect
    	status: no carrier
    em2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:19:bb:e9:ea:c2
    	media: Ethernet autoselect
    	status: no carrier
    em3: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:19:bb:e9:ea:c3
    	media: Ethernet autoselect
    	status: no carrier
    bge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0b:cd:4e:4e:ad
    	inet6 fe80::20b:cdff:fe4e:4ead%bge0 prefixlen 64 scopeid 0x5 
    	inet 83.***.144.19 netmask 0xfffff800 broadcast 255.255.255.255
    	media: Ethernet autoselect (1000baseTX <full-duplex>)
    	status: active
    bge1: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0b:cd:4e:51:0b
    	inet6 fe80::20b:cdff:fe4e:510b%bge1 prefixlen 64 scopeid 0x6 
    	media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7 
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=41 <up,running>metric 0 mtu 1460
    	pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    pflog0: flags=100 <promisc>metric 0 mtu 33204
    vlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:0b:cd:4e:51:0b
    	inet6 fe80::219:bbff:fee9:eac0%vlan0 prefixlen 64 scopeid 0xb 
    	inet 10.0.0.254 netmask 0xffffff00 broadcast 10.0.0.255
    	media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    	vlan: 1 parent interface: bge1
    vlan1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:0b:cd:4e:51:0b
    	inet6 fe80::219:bbff:fee9:eac0%vlan1 prefixlen 64 scopeid 0xc 
    	inet 10.0.20.254 netmask 0xffffff00 broadcast 10.0.20.255
    	media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    	vlan: 20 parent interface: bge1</full-duplex></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></promisc></up,running></up,loopback,running,multicast></full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,promisc,simplex,multicast></full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></broadcast,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></broadcast,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></broadcast,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></broadcast,simplex,multicast>
    

    dmesg

    Copyright (c) 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    	The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-RELEASE-p5 #0: Sun Dec  6 22:57:48 EST 2009
        sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Xeon(TM) CPU 2.40GHz (2399.33-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0xf27  Stepping = 7
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x4400 <cnxt-id,xtpr>Logical CPUs per core: 2
    real memory  = 1073717248 (1023 MB)
    avail memory = 1036845056 (988 MB)
    ACPI APIC Table: <compaq 00000083="">
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
     cpu0 (BSP): APIC ID:  6
     cpu1 (AP/HT): APIC ID:  7
    MADT: Forcing active-low polarity and level trigger for SCI
    ioapic0 <version 1.1=""> irqs 0-15 on motherboard
    ioapic1 <version 1.1=""> irqs 16-31 on motherboard
    ioapic2 <version 1.1=""> irqs 32-47 on motherboard
    ioapic3 <version 1.1=""> irqs 48-63 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    cryptosoft0: <software crypto=""> on motherboard
    padlock0: No ACE support.
    acpi0: <compaq p31=""> on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
    acpi_timer0: <32-bit timer at 3.579545MHz> port 0x920-0x923 on acpi0
    pcib0: <acpi host-pci="" bridge=""> on acpi0
    pci0: <acpi pci="" bus=""> on pcib0
    vgapci0: <vga-compatible display=""> port 0x2400-0x24ff mem 0xf6000000-0xf6ffffff,0xf5ff0000-0xf5ff0fff at device 3.0 on pci0
    ciss0: <compaq smart="" array="" 5i=""> port 0x2800-0x28ff mem 0xf5f80000-0xf5fbffff,0xf5df0000-0xf5df3fff irq 31 at device 4.0 on pci0
    ciss0: [ITHREAD]
    pci0: <base peripheral=""> at device 5.0 (no driver attached)
    pci0: <base peripheral=""> at device 5.2 (no driver attached)
    isab0: <pci-isa bridge=""> at device 15.0 on pci0
    isa0: <isa bus=""> on isab0
    atapci0: <serverworks csb5="" udma100="" controller=""> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x2000-0x200f at device 15.1 on pci0
    ata0: <ata 0="" channel=""> on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel=""> on atapci0
    ata1: [ITHREAD]
    ohci0: <ohci (generic)="" usb="" controller=""> mem 0xf5e70000-0xf5e70fff irq 10 at device 15.2 on pci0
    ohci0: [GIANT-LOCKED]
    ohci0: [ITHREAD]
    usb0: OHCI version 1.0, legacy support
    usb0: SMM does not respond, resetting
    usb0: <ohci (generic)="" usb="" controller=""> on ohci0
    usb0: USB revision 1.0
    uhub0: <(0x1166) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
    uhub0: 4 ports with 4 removable, self powered
    pcib1: <acpi host-pci="" bridge=""> on acpi0
    pci1: <acpi pci="" bus=""> on pcib1
    pcib2: <pci-pci bridge=""> at device 1.0 on pci1
    pci2: <pci bus=""> on pcib2
    em0: <intel(r) 1000="" pro="" network="" connection="" 6.9.6=""> port 0x3000-0x303f mem 0xf7ee0000-0xf7efffff,0xf7e80000-0xf7ebffff irq 28 at device 4.0 on pci2
    em0: [FILTER]
    em0: Ethernet address: 00:19:bb:e9:ea:c0
    em1: <intel(r) 1000="" pro="" network="" connection="" 6.9.6=""> port 0x3040-0x307f mem 0xf7e60000-0xf7e7ffff irq 27 at device 4.1 on pci2
    em1: [FILTER]
    em1: Ethernet address: 00:19:bb:e9:ea:c1
    em2: <intel(r) 1000="" pro="" network="" connection="" 6.9.6=""> port 0x3080-0x30bf mem 0xf7e40000-0xf7e5ffff irq 28 at device 6.0 on pci2
    em2: [FILTER]
    em2: Ethernet address: 00:19:bb:e9:ea:c2
    em3: <intel(r) 1000="" pro="" network="" connection="" 6.9.6=""> port 0x30c0-0x30ff mem 0xf7e20000-0xf7e3ffff irq 27 at device 6.1 on pci2
    em3: [FILTER]
    em3: Ethernet address: 00:19:bb:e9:ea:c3
    bge0: <compaq nc7781="" gigabit="" server="" adapter,="" asic="" rev.="" 0x1002=""> mem 0xf7df0000-0xf7dfffff irq 30 at device 2.0 on pci1
    miibus0: <mii bus=""> on bge0
    brgphy0: <bcm5703 10="" 100="" 1000basetx="" phy=""> PHY 1 on miibus0
    brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    bge0: Ethernet address: 00:0b:cd:4e:4e:ad
    bge0: [ITHREAD]
    pcib3: <acpi host-pci="" bridge=""> on acpi0
    pci4: <acpi pci="" bus=""> on pcib3
    bge1: <compaq nc7781="" gigabit="" server="" adapter,="" asic="" rev.="" 0x1002=""> mem 0xf7ff0000-0xf7ffffff irq 29 at device 2.0 on pci4
    miibus1: <mii bus=""> on bge1
    brgphy1: <bcm5703 10="" 100="" 1000basetx="" phy=""> PHY 1 on miibus1
    brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    bge1: Ethernet address: 00:0b:cd:4e:51:0b
    bge1: [ITHREAD]
    acpi_tz0: <thermal zone=""> on acpi0
    speaker0: <pc speaker=""> port 0x61 on acpi0
    atkbdc0: <keyboard controller="" (i8042)=""> port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard=""> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    sio0: <standard pc="" com="" port=""> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    sio0: [FILTER]
    fdc0: <floppy drive="" controller="" (fde)=""> port 0x3f2-0x3f5 irq 6 drq 2 on acpi0
    fdc0: [FILTER]
    fd0: <1440-KB 3.5" drive> on fdc0 drive 0
    cpu0: <acpi cpu=""> on acpi0
    p4tcc0: <cpu frequency="" thermal="" control=""> on cpu0
    cpu1: <acpi cpu=""> on acpi0
    p4tcc1: <cpu frequency="" thermal="" control=""> on cpu1
    pmtimer0 on isa0
    orm0: <isa option="" roms=""> at iomem 0xc0000-0xc7fff,0xc8000-0xcbfff,0xcc000-0xccfff,0xcd000-0xce7ff,0xee000-0xeffff pnpid ORM0000 on isa0
    sc0: <system console=""> at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga=""> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ukbd0: <logitech 0="" 2="" hid="" compliant="" keyboard,="" class="" 0,="" rev="" 1.10="" 1.80,="" addr=""> on uhub0
    kbd2 at ukbd0
    uhid0: <logitech 0="" 2="" hid="" compliant="" keyboard,="" class="" 0,="" rev="" 1.10="" 1.80,="" addr=""> on uhub0
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    acd0: CDROM <crn-8245b 2.19=""> at ata0-master PIO4
    da0 at ciss0 bus 0 target 0 lun 0
    da0: <compaq raid="" 1 ="" volume="" ok=""> Fixed Direct Access SCSI-0 device 
    da0: 135.168MB/s transfers
    da0: Command Queueing Enabled
    da0: 69459MB (142253280 512 byte sectors: 255H 32S/T 17433C)
    SMP: AP CPU #1 Launched!
    Trying to mount root from ufs:/dev/da0s1a
    pflog0: promiscuous mode enabled
    bge1: promiscuous mode enabled
    vlan0: promiscuous mode enabled
    bge1: link state changed to UP
    vlan0: link state changed to UP
    vlan1: link state changed to UP</compaq></crn-8245b></logitech></logitech></generic></system></isa></cpu></acpi></cpu></acpi></floppy></standard></at></keyboard></pc></thermal></bcm5703></mii></compaq></acpi></acpi></bcm5703></mii></compaq></intel(r)></intel(r)></intel(r)></intel(r)></pci></pci-pci></acpi></acpi></ohci></ohci></ata></ata></serverworks></isa></pci-isa></compaq></vga-compatible></acpi></acpi></compaq></software></version></version></version></version></compaq></cnxt-id,xtpr></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>
    


  • Thanks for posting the information. It certainly looks as if bge1 (the VLAN parent link) should be gigabit capable.

    Have you checked the switch configuration? Perhaps when you enabled VLANs you inadvertently configured the link to pfSense LAN interface to 100Mbps.

    I don't know if its relevant, but bge1 and vlan0 are in promiscuous mode. I wonder why?

    I'm also not sure of this, but isn't VLAN ID 1 some sort of default. Are things different if you use (say) VLAN ID 10 instead?



  • Have you checked the switch configuration? Perhaps when you enabled VLANs you inadvertently configured the link to pfSense LAN interface to 100Mbps.

    I can't configure vlan speed only the speed on the port and it is set to auto and i have tried the max speed setting.

    I don't know if its relevant, but bge1 and vlan0 are in promiscuous mode. I wonder why?

    I have no idea.

    I'm also not sure of this, but isn't VLAN ID 1 some sort of default. Are things different if you use (say) VLAN ID 10 instead?

    Using that but there is no improvements.



  • I'd guess something is going wrong with the autonegotiation. The switch should be telling the pfSense NIC that the switch end of the link is gigabit capable and the pfSense NIC should be telling the switch that the NIC is gigabit capable.

    Suggest you try configuring the switch port to 1Gbps full duplex and see if that makes a difference.



  • I have been looking in the switch configuration and the manual for the switch and it seems that i can only force 100FDX. If i have it set to auto i can get 1000MbpsFullDuplexCopper.

    Is there a way to force pfsense to 1000FDX?



  • @Tagnard:

    Is there a way to force pfsense to 1000FDX?

    You can edit the configuration file, but I don't know if the change will be preserved over changes through the web GUI.

    For now, its probably best to use a shell command to make a temporary change to see if it improves the situation. I suggest

    ifconfig bge1 down

    ifconfig bge1 media 1000baseTX

    ifconfig bge1 up

    ifconfig bge1

    The last command is to display the interface status to make sure its in gigabit mode and has established link with the switch.

    I don't have any bge interfaces so I can do any testing. I suggest you also read the FreeBSD man pages for bge and ifconfig since the bge man page has a special note about 1000baseTX media. You can read the FreeBSD man pages at http://www.freebsd.org/cgi/man.cgi


  • Rebel Alliance Developer Netgate

    As an additional datapoint, I just helped someone setup some VLANs on em-based network cards yesterday and they did show as having 1000baseTX vlans.

    I see you have some Intel em cards in that box, have you tried using those for VLANs? Even as a test?



  • I'm starting to think that it is the switch or the autonegotiation between the server and the switch that may be the problem. When i switch bge0 and bge1 between wan and lan i still only get 100baseTX to the switch and 1000baseTX to my cable modem.

    Right now i'm testing the newest firmware of the switch and after that i may try a fresh install of pfsense. If that fails i will try the other NIC's that i have in the server.



  • I have found the problem. I have been debugging the switch and the router when i thought "fuckit" and i removed all the network kabels from the switch and placed it next to the router and i used a different cable nd it worked like a charm. I took my cabletester and noticed that my cable was faulty.

    So much debugging for a 5-10min fix.

    But thanks for all the help, i have learned alot these days.


Locked