SBC Mini-ITX 1GHz C7 AGP,FP,2xLAN,Audio ethernet not working



  • Hello All
    Appologies if this is the wrong area;

    I'm trying to use this motherboard - http://uk.rs-online.com/web/search/searchBrowseAction.html?method=getProduct&R=6784524

    bought from this supplier, and using an embedded image, I've tried various embedded versions and everyone sees the hardware etc, unfortunatly it fails to get its DHCP assigned IP from the DSL router and will not return a ping from a laptop directly connected via a cross over cable with a manual IP configured within the default subnet pfsense is using.

    ifconfig shows the LAN interface as having the IP address it configured its self with, the WAN interface doesnt show an IP,

    I've tried two motherboards now and the same problem exists,  I would have thought that since the hardware is found and shows in the console that it ought to work ?

    anyone got any pointers?



  • Did you configure the second interface as the WAN interface?

    When booted, what is the output of ifconfig -a?



  • I hadn't tried one of the nano images,
    I've now tried - pfSense-1.2.3-RELEASE-1g-nanobsd.img.gz and can report that this works 100% on the motherboard,

    I suspect it must have been some odd incompatibility with the ethernet drivers ?


Locked