Squid Setup



  • I'm using PFsense 2.0 Beta1 Fresh Install with Squid 2. My ISP proxy frequently got very slow and failed to fetch web pages.

    This is my currently network

    ISP –----------> my proxy.server (202.156.xx.xx))
            |
    Debian/Proxy server (gw and squid server)
            |
      LAN 192.168.1.0/24

    I configured as transparent mode on port 3128 to my debian/proxy server that bypass ISP proxy to my proxy server. everything working fine.

    But i would need to improve my network to the diagram below

    ISP/Proxy ---------------------------------> My Proxy server (202.156.xx.xx)
          |
    PFSense (gw)
          |
    Servers
          |
      Lan

    I want my LAN to use my proxy server (202.156.xx.xx), so  i tried to enable transparent mode on PFSense machine and upstream forwarding to my Proxy server (202.156.xx.xx) but it did not working. it always detected my ISP proxy instead of my proxy server.

    Please advise

    Thanks in advance

    Leap



  • Hello everyone,

    Please help me on this.

    Thanks



  • Sounds like your isp is running a transparent proxy and intercepting the requests. Maybe setup an openvpn tunnel between your firewalls to bypass their proxy



  • I was about to write the same as razorback yesterday.  The odd thing is that the Debian box was able to successfully bypass the ISP proxy.  What versions of Squid were/are you running on the Debian box and pfSense package?



  • i am using 2.7.3 stable on debian and 2.7.8 on Pfsense.
    My ISP already allowed my IP address to bypass their proxy server. But i still want to redirect to my own proxy server.

    Thanks


Locked