Squid proxy not doing anything



  • so turned on Squid, set it up, and went to a speed test site for my ISP and downloaded a couple of .bin files with no change in speed after i downloaded them the first time.

    Settings

    Proxy interface: LAN
    Allow users on interface: Checked
    Transparent proxy: Checked
    whitespace char. in URI: strip

    Hard Disk Cache Size 30000 (megabytes)
    Hard disk cache system: aufs
    Hard disk cache location: /var/squid/cache
    Memory cache size: 50 (megabytes)
    Minimum object size: 50 (kilobytes)
    Maximum Object size 700000 (kilobytes)
    Level 1 subdirectories: 16
    Memory replacement policy: LRU Last Recently Used Policy
    Cache replaceent policy: LRU
    Lowe Water mark %: 90
    High Water mark %: 95

    Allow Subnets: 192.168.0.0/24

    All other options are set to blank, 0, or are greyed out.

    Local users is completely blank.

    Not sure what i'm missing here, i added the Allow Subnets address on top of the Allow users on interface cause it wasn't working in the first place to make sure everyone on the switch was able to use the proxy but still no dice….



  • Lan is bridged? What if turn off Transparent and setup you browser to the proxy?



  • the pfSense router has DHCP enabled, and the LAN card connects to 48 Port switch with 3 vlans, so turning off transparent proxy is not useful to me  :(

    I suppose i could try non-transparent on one computer to see it i can get it working at all for troubleshooting…


Locked