LightSquid only updates manually



  • I have found that for some reason my LightSquid install only ever gets updated when I update it manually. I noticed this because I saw that openDNS was blocking access to sites that were not going into the logs that I see in LightSquid.

    On a related note if I try to go to the graph report in LightSquid I get a 500 error. I have tried setting the symlink suggested in some other threads that I have seen, but that didn't do anything for the 500 error.

    Version 1.2.3-RELEASE
    built on Sun Dec 6 23:21:36 EST 2009
    Platform pfSense

    Installed packages
    Backup 0.1.7
    Cron 0.2
    Fit123 1.0
    Lightsquid 1.7.1
    phpSysInfo 2.5.4
    squid 2.7.8_1

    If you need more info just ask as I don't know why this is happening or if it is something that I did wrong.

    More info added on 2010-05-13.

    I ran "pkg_delete lightsquid*", as mentioned in the following thread. I had already changed the symlink for "/usr/bin/perl" so that it pointed to "/usr/local/bin/perl" instead of "/usr/local/bin/perl5.10.1", as it had pointed earlier.

    http://forum.pfsense.org/index.php/topic,11594.30.html

    When I ran the following command "cat /var/log/lighttpd.error.log" I only got the following single line of output "2010-05-12 12:17:34: (log.c.172) server started".

    Edit #2 More info added on 2010-05-14.

    I noticed "jimp" mentioning running the following commands for the 500 error. So here they are. It comes from the same thread mentioned above.

    $ find / -name "GD.pm"
    /usr/local/lib/perl5/site_perl/5.8.8/mach/GD.pm
    
    $ pkg_info | grep -i "gd-2*"
    gd-2.0.35,1         A graphics library for fast creation of images
    p5-GD-2.39          A perl5 interface to Gd Graphics Library version2
    
    $ cat /var/db/pkg/p5-GD-2.39/+REQUIRED_BY
    lightsquid-1.7.1_1
    

    I have set squid to no longer rotate the logs which has made it so that I do get data from the previous day now. I'm glad to at least get some data.

    Here is the only cron job that I see that mentions squid.

    minute  	hour  	mday  	month  	wday  	who  	command
    15   	 0   	 *   	 *   	 *   	 root   	 /usr/bin/perl /usr/local/www/lightsquid/lightparser.pl yesterday  
    


  • i have similar problem. After upgrade frop 1.2.2 to 1.2.3,  and  install squid manually (i had problem with Per-host throttling)
    my LightSquid only updates manually

    crontab -l

    0 0 * * * /usr/local/sbin/squid -k rotate

    so crontab hasn't got job  /usr/bin/perl /usr/local/www/lightsquid/lightparser.pl yesterday
    but when i ran it from console  - nothing happened

    is there any solution?



  • Well I tested it over the weekend & I have it updating again. The issue is that you need to leave the "Log rotate" blank. For some reason LightSquid only checks the "/var/squid/log/access.log" file & ignores the "/var/squid/log/access.log.*" files that would be created by using setting "Log rotate" to something other than blank.

    Now to get the rest of the data in I just need to have some time when no one is using the Internet in the office so that I can merge files.



  • Don't worry more - bug is present.



  • Any ideas on the 500 error as I've tried everything I have seen so far & nothing has worked yet.



  • Ligtsquid cron fixed
    https://rcs.pfsense.org/projects/pfsense-packages/repos/mainline/commits/79682386f48650d6bb2a2d7f5d9f8ac9e6703a36

    2 joecr
    Call from shell
    /usr/local/www/lightsquid/lightparser.pl today

    What messages?



  • When I go to http://pfsense/lightsquid/graph.cgi?year=2010&month=05&mode=month I get a 500 error. The title of the image is "Graph Report".

    I ran the command after having some traffic & I saw the numbers change like I normally would if I click on either the "Refresh now" button or the "Refresh full" button.

    I then clicked on the "Reinstall this package." & "Reinstall this package's GUI components.", next to Lightsquid in the "Installed packages" tab of the "System: Package Manager" page, in the hopes that would get it to read the old files, but I don't see any change on that respect.

    It still doesn't update earlier days that I have data for in the files "/var/squid/log/access.log.0", "/var/squid/log/access.log.1", "/var/squid/log/access.log.2", "/var/squid/log/access.log.3", & "/var/squid/log/access.log.4". Even if I click on the "Refresh full" button, which to me sounds like it is supposed to look through the files that I just mentioned. I only have access.log, access.log.0, access.log.1, access.log.2, access.log.3, & access.log.4 because I told squid to stop using the "Log rotate". I would like to be able to use "Log rotate" with squid so that I don't have a file that is massive from multiple days of monitoring. I'd like a new file every day & to have the data show up in lightsquid.

    Hey I just looked at the cron jobs I now have a new one. So not only do I have the original one but the new on as well.

    minute  	hour  	mday  	month  	wday  	who  	command
    */50   	 *   	 *   	 *   	 *   	 root   	 /usr/bin/perl /usr/local/www/lightsquid/lightparser.pl today
    15   	 0   	 *   	 *   	 *   	 root   	 /usr/bin/perl /usr/local/www/lightsquid/lightparser.pl yesterday
    

    Thank you for fixing the issue of the cron job not being made, but as I noted earlier I still have the 500 error when I try to view a monthly graph & it isn't reading info from the old log files that were rotated by squid.



  • Pls show you pkg_info



  • Here is the result of running pkg_info.

    $ pkg_info
    arc-5.21o_1         Create & extract files from DOS .ARC files
    arj-3.10.22_1       Open-source ARJ
    bandwidthd-2.0.1_1  Tracks bandwidth usage by IP address
    clamav-0.95.1       Command line virus scanner written entirely in C
    db41-4.1.25_4       The Berkeley DB package, revision 4.1
    gd-2.0.35,1         A graphics library for fast creation of images
    gdbm-1.8.3_3        The GNU database manager
    gettext-0.17_1      GNU gettext package
    grub-0.97_3         GRand Unified Bootloader
    havp-0.90           HTTP Antivirus Proxy
    jpeg-6b_4           IJG's jpeg compression utilities
    lha-1.14i_6         Archive files using LZSS and Huffman compression (.lzh file
    libdnet-1.11_2      A simple interface to low level networking routines
    libiconv-1.11_1     A character set conversion library
    lightsquid-1.7.1_1  A light and fast web based squid proxy traffic analyser
    lua-5.1.3_3         Small, compilable scripting language providing easy access 
    mbmon-205_4         A tty motherboard monitor for LM78/79, W8378x, AS99127F, VT
    mysql-client-5.0.77 Multithreaded SQL database (client)
    mysql-client-5.1.44_1 Multithreaded SQL database (client)
    nano-2.0.9          Nano's ANOther editor, an enhanced free Pico clone
    openldap-client-2.4.10 Open source LDAP client implementation
    p5-GD-2.39          A perl5 interface to Gd Graphics Library version2
    packages            BSD Installer mega-package
    pcre-7.8            Perl Compatible Regular Expressions library
    pcre-8.00           Perl Compatible Regular Expressions library
    perl-5.10.1         Practical Extraction and Report Language
    perl-5.8.8_1        Practical Extraction and Report Language
    pkg-config-0.23_1   A utility to retrieve information about installed libraries
    sqlite3-3.6.10      An SQL database engine in a C library w/ Tcl wrapper
    squid-2.7.7         HTTP Caching Proxy
    squidGuard-1.3_1    A fast redirector for squid
    squid_radius_auth-1.10 RADIUS authenticator for squid proxy 2.5 and later
    unzoo-4.4_2         A zoo archive extractor
    vnstat-1.6_3        A console-based network traffic monitor
    
    

    That's interesting I thought I had removed havp through the web interface.


Locked