Lots of lost packets



  • Hi.  I am using pfSense 1.2.3 RELEASE and it work great.  Three weeks ago I changed from a 7MBPS service from my provider (Bell Canada) to a 10MBPS service.  For this, I had to change my modem from a speedstream (don't remember the model, I had to return it) to a 2Wire 2701HG.  I configured it to be bridged with my router to be able to access it from my LAN.  Since then, I see a lot of dropped packets in the RRD quality graphs but I don't see evident performance degradation.  The interface status page don't give any errors for WAN or LAN.  The only interface giving errors is the OPT1 interface, but it is not enabled and it is probably dated from the time it was enabled.  I did a packet capture on the WAN side with pfSense and checked it with wireshark, but I don't (or can't) find a clue to why it is happening.  Can someone help me diagnose this problem?  I included the strange RRD quality graph with this post. 
    ![One Month.jpg](/public/imported_attachments/1/One Month.jpg)
    ![One Month.jpg_thumb](/public/imported_attachments/1/One Month.jpg_thumb)
    ![Two Days.jpg](/public/imported_attachments/1/Two Days.jpg)
    ![Two Days.jpg_thumb](/public/imported_attachments/1/Two Days.jpg_thumb)


  • Rebel Alliance Developer Netgate

    You may just need to pick a different monitor IP for that connection.



  • I don't rember seeing any place where I can select an IP for monitoring in the RRD graphs or in the WAN interface configuration screen.  Can you give me more details?


  • Rebel Alliance Developer Netgate



  • Thank you for the tip.  It makes sense.  When there was traffic, there was no lost packets on my graphs.  So, I suppose pfSense use a preconfigured ip to ping when there is no traffic.  But, I first used the IP adress of the smtp server of my service provider (to be sure to be the closer possible from my router), no change.  I then used the ip addres of google, same thing.  I made sure I can ping both of them.  I also made sure to save the settings of the RRD page so it can restart and see the changes.

    I will try to reboot the router tonight when I will not cut the access to anyone.



  • Wait!  I backed up my config to see if the parameter was there and it is not.  I used the command "config['interfaces']['wan']['use_rrd_gateway'] = '66.249.81.104';" and made sure to press "execute".  Same thing.  I finally modified the configuration file directly and restored my router.  It seems to work now, but it is possibly one of those "no dropped packets" section I had in my graphs.  I will keep you informed.



  • Great.  It is working.  Thank you very much.  Is there any suggestions about what is the best choice for the address?  I mean, is the number of hop important (I suppose so), what qualifies a good choice?


  • Rebel Alliance Developer Netgate

    Usually a router or server at the ISP for that WAN link is the best choice.

    You could do a traceroute and just pick a hop that isn't too far away. DNS servers are good too.

    I just wouldn't use something waaaaay out there away from you in terms of hops. Though some people do that, there is a lot of room for error.



  • Thank you jimp.  That's what I thought.  Case closed.


Locked