ZNYX ZX346Q Quad Port 10/100



  • When I use this nic ZNYX ZX346Q Quad Port 10/100 PCI Ethernet Adaptor on a pfSense box and there are total 4 interfaces de0, de1, de2 and de3 but on every interface I get this error message abnormal interrupt: transmit underflow (raising TX threshold to 96|256) is this because the nic is broken or is it a driver problem or something else?



  • It's only a debug message of the driver that it's adjusting some parameters. Should be nothing to be concerned about as long as it's working fine.

    The xl driver (3coms) does output something similiar when adjusting parameters.



  • I forgot to say its impossible to use it cause everything is going super slow.



  • In that case it somehow seems borked. Check you bios for pnp settings. In case there is a setting disable pnp. Other thing to try is to use another pci slot. Also try to disable everything that's not needed in the bios (additional com ports, soundcard, midi,…) to free up resources.



  • @hoba:

    In that case it somehow seems borked. Check you bios for pnp settings. In case there is a setting disable pnp. Other thing to try is to use another pci slot. Also try to disable everything that's not needed in the bios (additional com ports, soundcard, midi,…) to free up resources.

    I tried changing another pci slots and disabled everything in bios but doesnt help do u got more idea's?



  • Not really. Browse the freebsd lists for this error message. Maybe it's a know bug of the driver and there is a workaround for it.



  • I don't know how much of this applies to pfSense, but with m0n0wall the included opensource driver has problems with this card, so you had to use the one provided my ZNYX. Nics are so cheap that we just bought a new one.


Locked